病毒侵袭

B - 病毒侵袭
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

当太阳的光辉逐渐被月亮遮蔽,世界失去了光明,大地迎来最黑暗的时刻。。。。在这样的时刻,人们却异常兴奋――我们能在有生之年看到500年一遇的世界奇观,那是多么幸福的事儿啊~~ 
但网路上总有那么些网站,开始借着民众的好奇心,打着介绍日食的旗号,大肆传播病毒。小t不幸成为受害者之一。小t如此生气,他决定要把世界上所有带病毒的网站都找出来。当然,谁都知道这是不可能的。小t却执意要完成这不能的任务,他说:“子子孙孙无穷匮也!”(愚公后继有人了)。 
万事开头难,小t收集了好多病毒的特征码,又收集了一批诡异网站的源码,他想知道这些网站中哪些是有病毒的,又是带了怎样的病毒呢?顺便还想知道他到底收集了多少带病毒的网站。这时候他却不知道何从下手了。所以想请大家帮帮忙。小t又是个急性子哦,所以解决问题越快越好哦~~ 
 

Input

第一行,一个整数N(1<=N<=500),表示病毒特征码的个数。 
接下来N行,每行表示一个病毒特征码,特征码字符串长度在20―200之间。 
每个病毒都有一个编号,依此为1―N。 
不同编号的病毒特征码不会相同。 
在这之后一行,有一个整数M(1<=M<=1000),表示网站数。 
接下来M行,每行表示一个网站源码,源码字符串长度在7000―10000之间。 
每个网站都有一个编号,依此为1―M。 
以上字符串中字符都是ASCII码可见字符(不包括回车)。 
 

Output

依次按如下格式输出按网站编号从小到大输出,带病毒的网站编号和包含病毒编号,每行一个含毒网站信息。 
web 网站编号: 病毒编号 病毒编号 … 
冒号后有一个空格,病毒编号按从小到大排列,两个病毒编号之间用一个空格隔开,如果一个网站包含病毒,病毒数不会超过3个。 
最后一行输出统计信息,如下格式 
total: 带病毒网站数 
冒号后有一个空格。 
 

Sample Input

     
     
3 aaa bbb ccc 2 aaabbbccc bbaacc
 

Sample Output

     
     
web 1: 1 2 3 total: 1
 
易错点:
   (1)  字符串中字符都是ASCII码可见字符
    (2) 每行一个含毒网站信息, web 网站编号: 病毒编号 病毒编号 … 

将上面的细节处理好了就AC了。

更快代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<queue>
#include<set>
using namespace std;

const int MAX = 210*510;

int kid[MAX][130],fail[MAX],v[MAX],num;
set<int> ve;

struct AcTrie
{
	int rt,L;
	//初始化
	void Init(){L=0;rt=newnode();}
	//新建节点
	int newnode(){
		v[L] = 0;
		memset(kid[L],-1,sizeof(kid[L]));
		return L++;
	}
	//建立trie树
	void insert(char* s){
		int now = rt;
		for(int i=0;s[i];++i){
			int t = s[i]-0;
			if(kid[now][t]==-1)
			kid[now][t] = newnode();
			now = kid[now][t];
		}
		v[now] = num;
	}
	//建立trie图
	void Build()
	{
		queue<int> q;
		for(int i=0;i<130;++i){
			if(kid[rt][i]==-1){
				kid[rt][i] = rt;
			}
			else {
				fail[kid[rt][i]] = rt;
				q.push(kid[rt][i]);
			}
		}
		while(!q.empty())
		{
			int now = q.front();q.pop();
			for(int i=0;i<130;++i){
				if(kid[now][i]==-1){
					kid[now][i] = kid[fail[now]][i];
				}
				else {
					fail[kid[now][i]] = kid[fail[now]][i];
					q.push(kid[now][i]);
				}
			}
		}
	}
	//查询
	void query(char* s)
	{
		int now = rt,tmp;
		for(int i=0;s[i];++i){
			int t = s[i]-0;
			now = tmp = kid[now][t];
			while(tmp!=rt)
			{
				if(v[tmp])ve.insert(v[tmp]);
				tmp = fail[tmp];
			}
		}
	}
}ac;

char str[100000+50];

int main()
{
#ifdef zsc
	freopen("input.txt","r",stdin);
#endif
	int n,m,i,j,k;
	
	while(~scanf("%d",&n))
	{
		int sum = 0;
		num = 0;
		ac.Init();
		while(n--)
		{
			scanf("%s",str);
			num++;
			ac.insert(str);
		}
		ac.Build();
		scanf("%d",&m);
		k = 0;
		while(m--)
		{
			ve.clear();
			scanf("%s",str);
			ac.query(str);
			k++;
			if(ve.size()>0){
				printf("web %d:",k);
				for(set<int>::iterator it=ve.begin();it!=ve.end();++it)
					printf(" %d",*it);
				printf("\n");
				sum ++;
			}
		}
		printf("total: %d\n",sum);
	}
	return 0;
}



AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<queue>
#include<set>
using namespace std;
#define MAX 210*510
int cnt,Count;//cnt病毒的网站编号,Count输入时的病毒编号
int cn,t,c;//cn总的病毒网站
set<int> a;
//储存病毒编号,因为有重复的病毒会导致重复储存,所有用set
set<int>::iterator it;
struct trie
{
	int root,L;
	int kid[MAX][130],fail[MAX],v[MAX];
	trie()
	{
		L=0;root = newnote();
	}
	int newnote();
	void insert(string str);
	void build();
	void query(string str);
}*ac;
int trie::newnote()
{
	v[L] = 0;
	memset(kid[L],-1,sizeof(kid[L]));
	return L++;
}
void trie::insert(string str)
{
	int now = root;
	for(int i=0;str[i];++i)
	{
		int d = str[i]-0;
		if(kid[now][d]==-1)
		{
			kid[now][d] = newnote();//第now的孩子申请一个空间
		}
		now = kid[now][d];
	}
	v[now] = Count;//字符串结束位置标明是几号病毒
}
void trie::build()
{
	int now;
	queue<int> p;
	for(int i=0;i<130;++i)
	{
		if(kid[root][i]==-1)
		   kid[root][i] = root;
		else
		{
			fail[kid[root][i]] = root;
			//root下的孩子kid[root][i]的上一个位置是root
			p.push(kid[root][i]);
		}
	}
	//上面已经对根节点和他的孩子都做了失败处理fail【】
	while(!p.empty())
	{
		now = p.front();p.pop();
		for(int i=0;i<130;++i)
		{
			if(kid[now][i]==-1)
			{
				kid[now][i] = kid[fail[now]][i];
				/*
				现在节点kid无值,所以拿现在节点的上一个节点
				的kid值
				*/
			}
			else
			{
				fail[kid[now][i]] = kid[fail[now]][i];
				p.push(kid[now][i]);
			}
		}
	}
}
void trie::query(string str)
{
	c=0;
	int tmp,now=root;
	for(int i=0;str[i];++i)
	{
		tmp = now = kid[now][str[i] - 0];
			while(tmp!=root)
			{
				if(v[tmp])
				{a.insert(v[tmp]);c++;}
				tmp = fail[tmp];
			}
	}
}
void OuT()
{
	cout << "web " << cnt <<":";
	for(it=a.begin();it!=a.end();++it)
	{
		cout << " " << *it;
	}
	cout << endl;
	a.clear();
}
int main()
{
	/*freopen("input.txt","r",stdin);*/
	string str;
	int n,m;
	while(cin >> n)
	{
		cnt = 0;
		ac = new trie; 
		Count=0;
		while(n--)
		{
			Count++;
			cin >> str;
			ac->insert(str);
		}
		cin >> m;
		ac->build();cn=0;
		while(m--)
		{
			t=0;
			cnt++;
			cin >> str;
			ac->query(str);
			if(c){cn++;OuT();}
		}
		cout << "total: " << cn << endl;
		delete ac;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值