Light Bulb(三分)

B - Light Bulb
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. Dis distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000
 
   
这题的比值转换,与公式好多都不会了。感觉做起来很吃力。三分不难,难在公式的推导。
 
   
AC代码:
 
   
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
#define T 100
#define eps 1e-10
typedef long long ll;
int N;
double H,h,D;
double Cal(double x)
{
	return H+D-((H-h)*D/x+x);
}
double BS(double l,double r)
{
	double L=l,R=r,mid,midmid;
	while(L+eps<R)
	{
		mid = (L+R)/2;
		midmid=(mid+R)/2;
		if(Cal(mid)<=Cal(midmid)){
			L=mid;
		}
		else
		{
			R=midmid;
		}
	}
	return Cal(max(mid,midmid));
}
int main()
{
    /*freopen("input.txt","r",stdin); */
	scanf("%d",&N);
	while(N--)
	{
		scanf("%lf%lf%lf",&H,&h,&D);
		double t,x,y;
		x = D*h/H;//一开始不知道竟然可以x/D=h/H的
		t = D-x;
		printf("%.3lf\n",max(BS(t,D),h));
	}
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值