POJ 1679-The Unique MST( 判断最小生成树的唯一性)

B - The Unique MST
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!
 
   
 
   
这题与csu1541很像,以为直接粘贴就能A了,结果Wa。。。
 
   
 
   
思路:
以数据
6 7
1 3 1
1 2 2
2 3 3
3 4 0
4 6 5
4 5 4
5 6 6
 
   
2014030403015
 
   
如果不特判0的时候,会将0也选入最小生成树内,这就会造成原本要选5个点就结束,但是这是不考虑0边时,最多也是拿到4个点就已经不能再拿了,所以答案与之前的最小生成树的值相同了,所以就会认为有另外一颗最小的树,其实是同一棵。所以我们就要将是0权值的都去掉,因为要不要0的边结果是一样的(当不足n条边时)。
 
   
AC代码:
 
   
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<vector>
typedef unsigned long long ll;
using namespace std;
#define T 5500000
int n,m,c;
int par[T];
int nu[T];
struct node
{
	int u,v,w;
	bool operator<(const node& a)const{
		return w<a.w;
	}
}e[T];
int find(int x)
{
	int s = x;
	for(;s!=par[s];s=par[s]);
	while(s!=x)
	{
		int tmp = par[x];
		par[x] = s;
		x = tmp;
	}
	return s;
}
int kruskal(int x)
{
	for(int i=0;i<=n;++i){
		par[i] = i;
	}
	int num = 0, cost = 0;
	for(int i=0;i<m;++i){
		if(x==i||!e[i].w)continue;//易错点
		int tx = find(e[i].u),ty = find(e[i].v);
		if(tx!=ty){
			par[tx] = ty;
			cost += e[i].w;
			num++;
			if(x==-1)nu[c++] = i;
		}
		if(num==n-1)break;
	}
	return cost;
}
int main()
{
#ifdef zsc
 freopen("input.txt","r",stdin);
#endif 
 
 int N,i;
 scanf("%d",&N);
  while(N--)
  {
	  scanf("%d%d",&n,&m);
	  c = 0;
	  for(i=0;i<m;++i){
		  scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
	  }
	  sort(e,e+m);
	  int w1 = kruskal(-1),w2;
	  bool flag = false;
	  for(i=0;i<c;++i){
		  w2 = kruskal(nu[i]);
		  if(w2==w1){
			  printf("Not Unique!\n");flag =true;
			  break;
		  }
	  }
	  if(!flag){
		  printf("%d\n",w1);
	  }
  }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值