CSU 1684-Disastrous Downtime(set+二分)

D - Disastrous Downtime
Time Limit:1000MS     Memory Limit:131072KB     64bit IO Format:%lld & %llu

Description

Input

Output

Sample Input

2 1
0
1000

3 2
1000
1010
1999

Sample Output

1
2
AC代码:
#include<iostream>
#include<functional>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<queue>
#include<set>
using namespace std;

typedef long long ll;
typedef unsigned long long ull;

#define T 100000 + 50

struct node
{
	ll v;
	bool operator<(const node& b)const{
		return v<b.v;
	}
}a[T];

struct line
{
	ll val;
	line():val(0){}
	line(ll _2):val(_2){}
	bool operator<(const line& b)const{
		return val>b.val;
	}
};

ll v[T];

bool cmp(const ll& a,const ll& b){return a>b;}

int main()
{
#ifdef zsc
	freopen("input.txt","r",stdin);
#endif
	int n,m,i,j;
	while(~scanf("%d%d",&n,&m))
	{
		ll c = 0;
		ll sum = 0;
		for(i=0;i<n;++i){
			scanf("%lld",&a[i].v);
		}
		sort(a,a+n);
		fill(v,v+T,0);
		multiset< ll,greater<int> > Q;
		multiset< ll,greater<int> >::iterator it;
		ll k;
		Q.insert(a[0].v+1000);
		ll cnt;
		for(i=1;i<n;++i){
 			it = Q.begin();
			k = *it;
   			it = Q.lower_bound(a[i].v);
			if(it==Q.end()){
				Q.insert(a[i].v+1000);
			}
			else if(it!=Q.end()){
				 Q.erase(it);
				Q.insert(a[i].v+1000);
			}
		}
		cnt = Q.size();
		Q.clear();
		/*if(m==1){
			printf("%lld\n",cnt);
			continue;
		}*/
		if(cnt%m>0){
			cnt = cnt/m+1;
		}
		else {
			cnt = cnt/m;
		}
		printf("%lld\n",cnt);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值