hihocoder,1400 : Composition

时间限制:10000ms
单点时限:1000ms
内存限制:256MB
描述
Alice writes an English composition with a length of N characters. However, her teacher requires that M illegal pairs of characters cannot be adjacent, and if ‘ab’ cannot be adjacent, ‘ba’ cannot be adjacent either.

In order to meet the requirements, Alice needs to delete some characters.

Please work out the minimum number of characters that need to be deleted.

输入
The first line contains the length of the composition N.

The second line contains N characters, which make up the composition. Each character belongs to ‘a’..’z’.

The third line contains the number of illegal pairs M.

Each of the next M lines contains two characters ch1 and ch2,which cannot be adjacent.

For 20% of the data: 1 ≤ N ≤ 10

For 50% of the data: 1 ≤ N ≤ 1000

For 100% of the data: 1 ≤ N ≤ 100000, M ≤ 200.

输出
One line with an integer indicating the minimum number of characters that need to be deleted.

样例提示
Delete ‘a’ and ‘d’.

样例输入
5
abcde
3
ac
ab
de
样例输出
2

解题思路:题目意思是给出一个字符串和一些敏感词,在字符串中找到需要剔除多少个字符才能够不含敏感词,实际上是在找最长子序列。费了很有时间才理解dp的做法,因为都是小写字符,设计一个table来表达敏感词中相邻的状态。然后遍历字符串,依次和所有小写字母比较,dp[i]表示以i字符为结尾的最长子序列长度,实际上这个长度也是由其他dp元素共同决定的,所以在遍历字符串的过程中需要和所有小写字母比较,更新dp。最后确定了dp数组之后,需要剔除的就是n-max(dp)。
找时间多做些动态规划的题目吧。



import java.util.Scanner;


public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);

        while(sc.hasNext()){
            int n = sc.nextInt();
            String str = sc.next();
            int[] dp = new int[26];
            int m = sc.nextInt();
            int[][] table = new int[26][26];
            while(m != 0){
                String s = sc.next();
                int left = s.charAt(0)-'a';
                int right = s.charAt(1)-'a';
                table[left][right] = 1;
                table[right][left] = 1;
                m--;
            }

            for(int i = 0; i < str.length(); i++){
                int tmp = 1;
                int index = str.charAt(i)-'a';
                for(int j = 0; j < 26; j++){
                    if(table[index][j] != 1){
                        tmp = Math.max(dp[j]+1, tmp);
                    }
                }
                dp[index] = tmp;
            }
            int maxlen = 0;
            for(int i = 0; i < dp.length; i++){
                if(maxlen < dp[i]) maxlen = dp[i];
            }
            System.out.println(n-maxlen);
        }
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值