Can you solve this equation?(HDU 2199)

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 33378    Accepted Submission(s): 13830


 

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

 

Sample Input
 
2 100 -4
 

 

Sample Output
 
1.6152 No solution!

思路:二分裸题,求满足Y的x的最小值,如果mid代入>=y,那么从(l,mid)中找。反之在(mid,r)中找。


代码上的总结:不要用cout输出保留精度,会有问题。用printf


#include<iostream>
#include<algorithm>
#include<iomanip>
#include<cmath>
typedef long long LL;
using namespace std;
int  y;

double dsearch(double  l,double r)
{
	while(r-l>1e-8)
	{
		double mid=(l+r)/2;
		if(8*pow(mid,4)+7*pow(mid,3)+2*pow(mid,2)+3*mid+6>=y) r=mid;
		else l=mid;
	}
return r;	
}


int main(void)
{
	int  t;cin>>t;
	while(t--)
	{
		cin>>y;
		if(8*pow(0,4)+7*pow(0,3)+2*pow(0,2)+3*0+6>y||8*pow(100,4)+7*pow(100,3)+2*pow(100,2)+3*100+6<y)
		cout<<"No solution!"<<endl;
		else 
		{
			double p=dsearch(0,100);
	///		cout<<setprecision(5)<<p<<endl;  做题输出精度不推荐cout,这样交上去是wa的
			printf("%.4f\n",p); 
		}
	}
return 0;	
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值