String Matching(poj1580)

String Matching

Time Limit: 1000MS Memory Limit: 10000K

Description

It's easy to tell if two words are identical - just check the letters. But how do you tell if two words are almost identical? And how close is "almost"? 

There are lots of techniques for approximate word matching. One is to determine the best substring match, which is the number of common letters when the words are compared letter-byletter. 

The key to this approach is that the words can overlap in any way. For example, consider the words CAPILLARY and MARSUPIAL. One way to compare them is to overlay them: 

CAPILLARY 
MARSUPIAL 

There is only one common letter (A). Better is the following overlay: 
CAPILLARY

     MARSUPIAL

with two common letters (A and R), but the best is: 
   CAPILLARY

MARSUPIAL

Which has three common letters (P, I and L). 

The approximation measure appx(word1, word2) for two words is given by: 
common letters * 2 
----------------------------- 
length(word1) + length(word2)

Thus, for this example, appx(CAPILLARY, MARSUPIAL) = 6 / (9 + 9) = 1/3. Obviously, for any word W appx(W, W) = 1, which is a nice property, while words with no common letters have an appx value of 0.

Input

The input for your program will be a series of words, two per line, until the end-of-file flag of -1. 
Using the above technique, you are to calculate appx() for the pair of words on the line and print the result. 
The words will all be uppercase.

Output

Print the value for appx() for each pair as a reduced fraction,Fractions reducing to zero or one should have no denominator.

Sample Input

CAR CART
TURKEY CHICKEN
MONEY POVERTY
ROUGH PESKY
A A
-1

Sample Output

appx(CAR,CART) = 6/7
appx(TURKEY,CHICKEN) = 4/13
appx(MONEY,POVERTY) = 1/3
appx(ROUGH,PESKY) = 0
appx(A,A) = 1
#include<iostream>
#include<string>
using namespace std;
int main(){
	string s1, s2;
	cin >> s1;
	while (s1 != "-1"){
		cin >> s2;
		if (s1 == s2)
			cout << "appx(" << s1 << ',' << s2 << ") = 1\n";
		else{
			int com = 0;
			int len1 = s1.length(), len2 = s2.length();
			for (int i = 0; i < len1; ++i){
				int cc = 0;
				for (int j = 0; (j + i < len1) and (j < len2); ++j)
					if (s1[i+j] == s2[j]) ++cc;
				if (cc > com) com = cc;
			}
			for (int i = 0; i < len2; ++i){
				int cc = 0;
				for (int j = 0; (j + i < len2) and (j < len1); ++j)
					if (s2[i+j] == s1[j]) ++cc;
				if (cc > com) com = cc;
			}
			com *= 2;
			int len = len1 + len2;
			for(int i = 2; i <= com ; ++i)
				if (com % i == 0 and len % i == 0){
					while (com % i == 0 and len % i == 0){
						com /= i;
						len /= i;
					}
				}
			if (com == 0)
				cout << "appx(" << s1 << ',' << s2 << ") = 0\n";
			else
				cout << "appx(" << s1 << ',' << s2 << ") = " << com << '/' << len << endl;
		}
		cin >> s1;
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值