POJ-1981 Circle and Points【单位圆覆盖最大点数】

You are given N points in the xy-plane. You have a circle of radius one and move it on the xy-plane, so as to enclose as many of the points as possible. Find how many points can be simultaneously enclosed at the maximum. A point is considered enclosed by a circle when it is inside or on the circle.
在这里插入图片描述
Input
The input consists of a series of data sets, followed by a single line only containing a single character ‘0’, which indicates the end of the input. Each data set begins with a line containing an integer N, which indicates the number of points in the data set. It is followed by N lines describing the coordinates of the points. Each of the N lines has two decimal fractions X and Y, describing the x- and y-coordinates of a point, respectively. They are given with five digits after the decimal point.
You may assume 1 <= N <= 300, 0.0 <= X <= 10.0, and 0.0 <= Y <= 10.0. No two points are closer than 0.0001. No two points in a data set are approximately at a distance of 2.0. More precisely, for any two points in a data set, the distance d between the two never satisfies 1.9999 <= d <= 2.0001. Finally, no three points in a data set are simultaneously very close to a single circle of radius one. More precisely, let P1, P2, and P3 be any three points in a data set, and d1, d2, and d3 the distances from an arbitrarily selected point in the xy-plane to each of them respectively. Then it never simultaneously holds that 0.9999 <= di <= 1.0001 (i = 1, 2, 3).

Output
For each data set, print a single line containing the maximum number of points in the data set that can be simultaneously enclosed by a circle of radius one. No other characters including leading and trailing spaces should be printed.

Sample Input
3
6.47634 7.69628
5.16828 4.79915
6.69533 6.20378
6
7.15296 4.08328
6.50827 2.69466
5.91219 3.86661
5.29853 4.16097
6.10838 3.46039
6.34060 2.41599
8
7.90650 4.01746
4.10998 4.18354
4.67289 4.01887
6.33885 4.28388
4.98106 3.82728
5.12379 5.16473
7.84664 4.67693
4.02776 3.87990
20
6.65128 5.47490
6.42743 6.26189
6.35864 4.61611
6.59020 4.54228
4.43967 5.70059
4.38226 5.70536
5.50755 6.18163
7.41971 6.13668
6.71936 3.04496
5.61832 4.23857
5.99424 4.29328
5.60961 4.32998
6.82242 5.79683
5.44693 3.82724
6.70906 3.65736
7.89087 5.68000
6.23300 4.59530
5.92401 4.92329
6.24168 3.81389
6.22671 3.62210
0

Sample Output
2
5
5
11

题意:求单位圆最多能包含多少个点
O(n^3)做法

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
const double eps=1e-8;
struct Point{
	double x,y;
}p[1010];
double dist(Point a,Point b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
void getmid(Point p1,Point p2,Point &center){//计算圆心坐标画图即可看出
	Point mid;
	mid.x=(p1.x+p2.x)/2.0;mid.y=(p1.y+p2.y)/2.0;
	double angle=atan2(p2.y-p1.y,p2.x-p1.x);
	double d=sqrt(1-dist(p1,mid)*dist(p1,mid));
	center.x=mid.x+d*sin(angle);
	center.y=mid.y-d*cos(angle);
}
int main(){
	int n;
	while(scanf("%d",&n)&&n){
		for(int i=0;i<n;i++) scanf("%lf%lf",&p[i].x,&p[i].y);
		int ans=1;
		for(int i=0;i<n;i++){ //枚举任意两个点构成圆上的弦 
			for(int j=i+1;j<n;j++){
				if(dist(p[i],p[j])>2.0) continue;
				Point center;
				getmid(p[i],p[j],center); //求出圆的圆心 
				int cnt=0;
				for(int k=0;k<n;k++) if(dist(p[k],center)<1.0+eps) cnt++; //求在此单位圆点的数量 
				ans=max(ans,cnt); 
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

扫描线做法 O(n^2logn)

#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
using namespace std;
#define maxn 1010
#define INF 0x3f3f3f3f
typedef long long ll;
const double eps=1e-8;
const double pi=acos(-1.0);
struct Point{
    double x,y;
}p[maxn];
struct node{
    double ang;
    int in;
}arc[maxn*maxn];
double dist(Point a,Point b){
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int dcmp(double x){
    if(fabs(x)<eps) return 0;
    else return x<0?-1:1;
}
bool cmp(node a,node b){
    if(dcmp(a.ang-b.ang)==0) return a.in>b.in;
    return dcmp(a.ang-b.ang)<0;
}
int main(){
    int n;
    while(scanf("%d",&n)&&n){
        for(int i=1;i<=n;i++) scanf("%lf%lf",&p[i].x,&p[i].y);
        int g=0;
        int ans=0,maxz=1;
        for(int i=1;i<=n;i++){
        	//固定i点为圆心的单位圆 
            ans=0; g=0;
            for(int j=1;j<=n;j++){
                if(dist(p[i],p[j])>2.0) continue;
                double ang1=atan2(p[j].y-p[i].y,p[j].x-p[i].x);
                double ang2=acos(dist(p[i],p[j])/2);
                //两个圆相交就会产生两个交点,这两个交点及其中点做为圆心都会过p[i],p[j] 
                //arc记录相交的两个点的斜率,用角度表示
                arc[++g].ang=ang1-ang2; arc[g].in= 1;
                arc[++g].ang=ang1+ang2; arc[g].in=-1;
            }
            //极角排序,角度小的排在前,判断被覆盖最多的弧,
			//被覆盖相当于这个弧上的点为圆心的圆可以覆盖到覆盖它的那些点,
			//所以被覆盖最多的弧就是答案了。 
            sort(arc+1,arc+g+1,cmp);
            for(int j=1;j<=g;j++){
                ans+=arc[j].in;
                maxz=max(maxz,ans);
            }
        }
        printf("%d\n",maxz);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值