hdu1171 二进制优化背包问题

Big Event in HDU

Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don’t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 – the total number of different facilities). The next N lines contain an integer V (0

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2
10 1
20 1
3
10 1
20 2
30 1
-1

Sample Output

20 10
40 40

题意:给定n个物品,个数为num,价值为value,将总价值分成两部分,其实尽可能的接近。
思路:背包问题。dp[j]表示价值为j是否存在。
转移方程dp[j]|=dp[j-v[i]];
坑:从sum/2 开始找,如果是奇数则先输出小再输出大。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=55,M=105;
int n,m;
int v[N*10];
int dp[N*N*M];
int main()
{
    while(scanf("%d",&n)!=EOF){
            if(n<0)break;
            int sum=0;
            int num,cnt=0,value;
            memset(dp,0,sizeof(dp));
            for(int i=1;i<=n;i++){
                scanf("%d%d",&value,&num);
                sum+=value*num;
                int t=1;
                while(num>t){
                    v[++cnt]=t*value;
                    num-=t;
                    t<<=1;
                }
                v[++cnt]=num*value;
            }
            dp[0]=1;
            for(int i=1;i<=cnt;i++)
                for(int j=sum;j>=v[i];j--){
                   dp[j]|=dp[j-v[i]];
                }
            for(int i=sum/2;i>=0;i--)//从中间往小找
            {
                if(dp[i]){
                    printf("%d %d\n",sum-i,i);
                    break;
                }
            }
          /*  int i;
            i=sum%2?(sum/2+1):(sum/2);//从中间往大的找要这么处理。
            for(;i<=sum;i++){
                if(dp[i]==1){
                    printf("%d %d\n",i,sum-i);
                    break;
                }
            }
            */
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值