Multiplication Puzzle POJ 1651

1 篇文章 0 订阅

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650


第一次接触dp呀,感觉好难的样子,这个题题目的意思是,给你n个数,选其中一个抽出来,然后得让它和它前面后面的一个数相乘,然后加起来,直到最后就剩2个数为止,一点要注意,就是收尾两个数字不能抽出来。

我也是看了一系列的博客,然后才写的,一个大的区域,先分成小的一块一块,设一个t,从2开始,求得一个一个小区间的最小值,从小扩到大。然后直到区间为0---n-1 即是最小的数目乘积。


代码如下


#include<stdio.h>
#include<string.>
#define MAXINT 0x7FFFFFFF //为long int  的最大值 
int main()
{
	int i,j,n,min=MAXINT;
	int s[110][110];
	int a[100];
	while(~scanf("%d",&n))
	{
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		int t=2;  //设t从2开始  得区间值 
		while(t<n)
		{
			for(i=0;i+t<n;i++)//[i,i+t]; 
			{
				min=MAXINT; 
				for(j=i+1;j<=i+t-1;j++)
				{
					int sum=s[i][j]+s[j][i+t]+a[i]*a[j]*a[i+t];
					if(sum<min)
					min=sum;
				}
				s[i][i+t]=min;  //求得区间的最小值 
			}
			t++;
		}
		printf("%d\n",s[0][n-1]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值