hdu 1789 Doing Homework again

5 篇文章 0 订阅

Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

本题是一个贪心的题目,题意是 做作业,一天只能完成一种,第一行是作业的规定限定期,
第二行是到了限定时间没做完,得扣掉相应分数,,让我们计算,怎么样做作业使得扣的分数
最少。那么 只要 先定义数组,对其进行排序, 分数大的在前面,时间早的在前面,之后当如
果是有的时间的空的,可以做后面的,如果是时间不够,那么就找前面会扣的分数最少的来替
这个,保证扣得分数最少。。

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
struct zuoye
{
	int data;
	int fenshu;
};
bool com(zuoye a,zuoye b)
{
	if(a.data==b.data)
	return a.fenshu>b.fenshu;
	else return a.data<b.data;
}
int main()
{
	int n,i,j,bbs;
	zuoye s[1010];
	int a[1010];
	cin>>bbs;
	while(bbs--)
	{
		memset(a,0,sizeof(a));
		cin>>n;
		for(i=0;i<n;i++)
		{
			cin>>s[i].data;
		}
		for(i=0;i<n;i++)
		{
			cin>>s[i].fenshu;
		}
		sort(s,s+n,com);
		int tian=1,tt=0,sum=0,min;
		for(i=0;i<n;i++)
		{
			if(s[i].data>=tian)
			{
				a[i]=1;
				tian++;
			}
			else 
			{
				min=s[i].fenshu;
				tt=i;
				for(j=0;j<=i-1;j++)
				{
					if(a[j]==1&&s[j].fenshu<min)
					{
						min=s[j].fenshu;
						tt=j;
					}
				}
				sum+=s[tt].fenshu;
				s[tt].fenshu=s[i].fenshu;
			}
		}
		cout<<sum<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值