hdu 1892 See you~

See you~

Problem Description

Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year. 
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles. 
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position. 

Input

In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed. 
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries. 
There are 4 kind of queries, sum, add, delete and move. 
For example: 
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points.
A x1 y1 n1 means I put n1 books on the position (x1,y1) 
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them. 
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them. 
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100. 

Output

At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries. 
For each "S" query, just print out the total number of books in that area. 

Sample Input

2
3
S 1 1 1 1
A 1 1 2
S 1 1 1 1
3
S 1 1 1 1
A 1 1 2
S 1 1 1 2

Sample Output

Case 1:
1
3
Case 2:
1
4
 
 
该题的话,是二维数组的应用,在 坐标下每个位置都有一本书,
题目描述 有四个类别来操作。所以先初始化s数组。然后,因为
后面有移走书本的操作,需要判断移走的本数是否足够,就定义个
a数组来记录书本的本数,然后  就是 四种类别的判断了。如果
是Q 就输出 x1 -》x2位置的书本本数,由坐标推得,
ans=sum(x2,y2)-sum(x2,y1-1)-sum(x1-1,y2)+sum(x1-1,y1-1)
。然后  就是 添减书本是 更新操作了,记得二维数组的坐标是
从1开始的。故每组输入 x y坐标的时候,都要增1.

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int ss[1005][1005]; //定义 保存书 
int a[1005][1005]; //记录书 
int lowbit(int x)
{
	return x&(-x);
}

int sum(int x,int y)  //求和 
{
	int suM=0;
	for(int i=x;i>0;i-=lowbit(i))
	{
		for(int j=y;j>0;j-=lowbit(j))
		{
			suM+=ss[i][j];
		}
	}
	return suM;
}

void updata(int x,int y,int z) //加减 
{
	for(int i=x;i<1005;i+=lowbit(i))
	{
		for(int j=y;j<1005;j+=lowbit(j))
		{
			ss[i][j]+=z;
		}
	}
}
int main()
{
	int n,m,bbs;
	scanf("%d",&bbs);
	char ch[5];
	int k=1;
	while(bbs--)
	{
		printf("Case %d:\n",k++);
		memset(ss,0,sizeof(ss));
		for(int i=1;i<1005;i++)
		{
			for(int j=1;j<1005;j++)
			{
				a[i][j]=1;
				updata(i,j,1);
			}
		} 
		scanf("%d",&n);
		int x1,y1,x2,y2;
		while(n--)
		{
			scanf("%s",ch);
			int ans=0;
			if(ch[0]=='S')
			{
				scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
				x1++;y1++;x2++;y2++;
				if(x1>x2) swap(x1,x2);
				if(y1>y2) swap(y1,y2);
				ans=sum(x1-1,y1-1)-sum(x2,y1-1)-sum(x1-1,y2)+sum(x2,y2);
				printf("%d\n",ans);
			}
			if(ch[0]=='A')
			{
				scanf("%d%d%d",&x1,&y1,&m);
				x1++;y1++;
				updata(x1,y1,m);
				a[x1][y1]+=m; //记录值 看之后的添减是否足够 
			}
			if(ch[0]=='D')
			{
				scanf("%d%d%d",&x1,&y1,&m);
				x1++;y1++;
				if(a[x1][y1]<m) m=a[x1][y1];
				a[x1][y1]-=m;
				updata(x1,y1,-m);
			}
			if(ch[0]=='M')
			{
				scanf("%d%d%d%d%d",&x1,&y1,&x2,&y2,&m);
				x1++;y1++;x2++;y2++;
				if(a[x1][y1]<m) m=a[x1][y1];
				a[x1][y1]-=m;
				a[x2][y2]+=m;
				updata(x1,y1,-m);
				updata(x2,y2,m);
			}			
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值