HPU15级练习(一)并查集 :B - Wireless Network

17 篇文章 0 订阅
9 篇文章 1 订阅
B - Wireless Network
Crawling in process... Crawling failed Time Limit:10000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL

SUCCESS

题意:N个电脑坏了,现在给出N和d(机器能联通的最大距离),然后输入N个电脑的坐标,接着输入O+电脑编号或S+电脑标号+电脑编号,(O代表修复某台电脑,S代表联通两个电脑),输出是否能联通两电脑。(如果两电脑距离小于等于d,则两电脑能连接)

#include <stdio.h>
struct xinxi
{
	int x;
	int y;
	int zt;
};
int pre[1010];
struct xinxi pc[1010];
int find(int x)
{
	int r=x;
	while(r!=pre[r])
	{
		r=pre[r];
	}
	return r;
}
void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
	}
}
int panduan(int i,int r,int d)//判断是否连接两机器 
{
	int p=pc[i].x-pc[r].x;
	int q=pc[i].y-pc[r].y;
	if(p*p+q*q<=d*d)
	{
		return 1;
	}
	else
	{
		return 0;
	}
}
int main()
{
	int n,d;
	scanf("%d%d",&n,&d);
	for(int i=1;i<=n;i++)
	{
		pre[i]=i;
		pc[i].zt=0;//初始化机器状态 
	}
	for(int i=1;i<=n;i++)
	{
		scanf("%d%d",&pc[i].x,&pc[i].y);
	}
	char op;
	while(scanf("%c",&op)!=EOF)
	{
		if(op=='O')
		{
			int r;
			scanf("%d",&r);
			pc[r].zt=1;
			for(int i=1;i<=n;i++)
			{
				if(i!=r&&pc[i].zt==1&&panduan(i,r,d)==1)
				{
					join(i,r);
				}
			}
		}
		if(op=='S')
		{
			int s,t;
			scanf("%d%d",&s,&t);
			int root1=find(s);
			int root2=find(t);
			if(root1==root2)//同根即联通了 
			{
				printf("SUCCESS\n");
			}
			else
			{
				printf("FAIL\n");
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值