HDU:4883 TIANKENG’s restaurant(区间计数)

TIANKENG’s restaurant

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 2559    Accepted Submission(s): 951


Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input
  
  
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output
  
  
11 6
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5746  5745  5744  5743  5742 
 

题目大意:

给你t批客人,每批有n个客人,给出每批客人来的时间段,并且每个来的客人都得拥有一个凳子,问这个饭店至少需要准备多少个凳子。

解题思路:

把时间变成数组区间,给区间加人数,然后求出人数最多的那个点对应的人数。

代码如下:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int group;
		int a[1450];
		memset(a,0,sizeof(a));
		scanf("%d",&group);
		for(int i=0;i<group;i++)
		{
			int people,t1,t2,t3,t4;
			scanf("%d %d:%d %d:%d",&people,&t1,&t2,&t3,&t4);
			int s=t1*60+t2;
			int e=t3*60+t4;
			for(int j=s+1;j<=e;j++)
			{
				a[j]=a[j]+people;
			}
		}
		sort(a,a+1450,cmp);
		printf("%d\n",a[0]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值