HDU:4006 The kth great number(优先队列)

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 9958    Accepted Submission(s): 3967


Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
 

Output
The output consists of one integer representing the largest number of islands that all lie on one line. 
 

Sample Input
  
  
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

Sample Output
  
  
1 2 3
Hint
Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
 

Source
 

Recommend
lcy

题目大意:给你一个n,一个k,代表n条命令,然后I+数字表示小明写了某个数字进入队列,Q表示求当前第k大 的元素,即倒数第k大的元素。
解题思路:优先队列,使队列里的数字从小到大排序,每进去一个新的,则pop到使队列保持size=k(把小的都删了),则此时的top即为倒数第k大的元素了。
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
using namespace std;
struct node
{
	int a;
	friend bool operator<(node x,node y)
	{
		return x.a>y.a;
	}
};
int main()
{
	int n,k;
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		char op;
		struct node tmp;
		priority_queue<node>q;
		for(int i=0;i<n;i++)
		{
			getchar();
			scanf("%c",&op);
			if(op=='I')
			{
				scanf("%d",&tmp.a);
				q.push(tmp);
				while(q.size()>k)//删除小的,只保存前k个大的 
				{
					q.pop();
				}
			}
			if(op=='Q')
			{
				printf("%d\n",q.top().a);
			}
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值