HDU:3665 Seaside(dijkstra算法求最短路径)

Seaside

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1560    Accepted Submission(s): 1136


Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
 

Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers S Mi and L Mi, which means that the distance between the i-th town and the S Mi town is L Mi.
 

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.
 

Sample Input
  
  
5 1 0 1 1 2 0 2 3 3 1 1 1 4 100 0 1 0 1
 

Sample Output
  
  
2
 

Source
 

Recommend

lcy


题目大意:给你一个n,代表有0~n-1这些节点,接下来n块数据,第i块数据第一行是说他所连接的点的个数和它是否是海,是海的话标记是1,不是海的话标记是0,然后接下来就是它所连接的节点的编号和所距的距离,主人公小Y住在0点,求一条路径使得小Y能到达海点且路径最短。

解题思路:新开一个数组记录每个节点是否是海,然后用dijkstra算法求0到每点的最短距离,然后扫一遍dis数组,某点是海的话更新ans。

代码如下:

#include <cstdio>
#include <cstring>
#define INF 0x3f3f3f3f
int map[15][15];
int flag[15];
int dis[15];
int vis[15];
int n;
void dj()
{
	memset(vis,0,sizeof(vis));
	for(int i=0;i<n;i++)
	{
		dis[i]=map[0][i];
	}
	vis[0]=1;
	for(int k=0;k<n;k++)
	{
		int min=INF;
		int pos=-1;
		for(int i=0;i<n;i++)
		{
			if(vis[i]==0&&dis[i]<min)
			{
				min=dis[i];
				pos=i;
			}
		}
		vis[pos]=1;
		dis[pos]=min;
		for(int i=0;i<n;i++)
		{
			if(vis[i]==0&&dis[i]>dis[pos]+map[pos][i])
			{
				dis[i]=dis[pos]+map[pos][i];
			}
		}
	}
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		memset(flag,0,sizeof(flag));//初始化标记海 
		for(int i=0;i<n;i++)//初始化距离 
		{
			for(int j=i;j<n;j++)
			{
				if(i==j)
				{
					map[i][j]=0;
				}
				else
				{
					map[i][j]=INF;
				}
			}
		}
		for(int i=0;i<n;i++)
		{
			int num,sea;
			scanf("%d%d",&num,&sea);
			if(sea==1)
			{
				flag[i]=1;
			}
			for(int j=0;j<num;j++)
			{
				int to,len;
				scanf("%d%d",&to,&len);
				if(map[i][to]>len)//储存距离 
				{
					map[i][to]=len;
					map[to][i]=len;
				}
			}
		}
		dj();
		int ans=INF;
		for(int i=0;i<n;i++)
		{
			if(flag[i]==1)//是海 
			{
				if(dis[i]<ans)//更新ans 
				{
					ans=dis[i];
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值