POJ:1126 Simply Syntax(思维)

Simply Syntax
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5546 Accepted: 2480

Description

In the land of Hedonia the official language is Hedonian. A Hedonian professor had noticed that many of her students still did not master the syntax of Hedonian well. Tired of correcting the many syntactical mistakes, she decided to challenge the students and asked them to write a program that could check the syntactical correctness of any sentence they wrote. Similar to the nature of Hedonians, the syntax of Hedonian is also pleasantly simple. Here are the rules: 


0.The only characters in the language are the characters p through z and N, C, D, E, and I. 

1.Every character from p through z is a correct sentence. 

2.If s is a correct sentence, then so is Ns. 

3.If s and t are correct sentences, then so are Cst, Dst, Est and Ist. 

4.Rules 0. to 3. are the only rules to determine the syntactical correctness of a sentence. 

You are asked to write a program that checks if sentences satisfy the syntax rules given in Rule 0. - Rule 4.

Input

The input consists of a number of sentences consisting only of characters p through z and N, C, D, E, and I. Each sentence is ended by a new-line character. The collection of sentences is terminated by the end-of-file character. If necessary, you may assume that each sentence has at most 256 characters and at least 1 character.

Output

The output consists of the answers YES for each well-formed sentence and NO for each not-well-formed sentence. The answers are given in the same order as the sentences. Each answer is followed by a new-line character, and the list of answers is followed by an end-of-file character.

Sample Input

Cp
Isz
NIsz
Cqpq

Sample Output

NO
YES
YES
NO

Source


题目大意:p~z的单个字母是一个句子,N+一个句子还是一个句子,C\D\E\I后面得加两个句子才构成一个句子,这里的句子能嵌套。给你一个字符串,问是否最终是一个句子。(这题上说保证属如不含其他字符,但是不是的。。。)
解题思路:从后往前扫,用一个num记录当前句子个数,一旦不符合规则就跳出循环。
代码如下:
#include <cstdio>
#include <cstring> 
char s[300];
int main()
{
	while(scanf("%s",s)!=EOF)
	{
		int size=strlen(s);
		size--;
		int num=0;//记录当前句子个数 
		int i=size;
		while(i>=0)
		{
			if(s[i]>='p'&&s[i]<='z')
			{
				num++;
			}
			else
			{
				if(s[i]=='C'||s[i]=='D'||s[i]=='E'||s[i]=='I')
				{
					num--;//  比如原来有两个句子st,那么遇到C D E I的话变成Cst 是一个句子 ,相当于是2+1-2=2-1=1个句子了  2+1是多了一个句子 -2是少了2个句子 
					if(num<1)//说明原先不足两个句子,那么遇到这种情况不能组成一个句子 
					{
						break;
					}
				}
				else
				{
					if(s[i]=='N')//这里不用num--   相当于num+1-1    多了一个N开头的句子,少了一个和N匹配的句子 
					{
						if(num<1)//原先不足一个句子和N匹配不成新的句子 
						{
							break;
						}
					}
					else//出现别的字符了,那么break 
					{
						num=-1;
						break;
					}
				}
			}
			i--;
		}
		if(num==1)//只有当最后是一个句子的时候才输出yes 
		{
			printf("YES\n");
		}
		else
		{
			printf("NO\n");
		}
	}
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值