1607: [Usaco2008 Dec]Patting Heads 轻拍牛头
Time Limit: 3 Sec Memory Limit: 64 MBSubmit: 2222 Solved: 1197
[ Submit][ Status][ Discuss]
Description
今天是贝茜的生日,为了庆祝自己的生日,贝茜邀你来玩一个游戏.
贝茜让N(1≤N≤100000)头奶牛坐成一个圈.除了1号与N号奶牛外,i号奶牛与i-l号
和i+l号奶牛相邻.N号奶牛与1号奶牛相邻.农夫约翰用很多纸条装满了一个桶,每一张包含了一个独一无二的1到1,000,000的数字.
接着每一头奶牛i从柄中取出一张纸条Ai.每头奶牛轮流走上一圈,同时拍打所有编号能整除在纸条上的数字的牛的头,然后做回到原来的位置.牛们希望你帮助他们确定,每一头奶牛需要拍打的牛.
Input
第1行包含一个整数N,接下来第2到N+1行每行包含一个整数Ai.
Output
第1到N行,每行的输出表示第i头奶牛要拍打的牛数量.
Sample Input
5 //有五个数,对于任一个数来说,其它的数有多少个是它的约数
2
1
2
3
4
INPUT DETAILS:
The 5 cows are given the numbers 2, 1, 2, 3, and 4, respectively.
2
1
2
3
4
INPUT DETAILS:
The 5 cows are given the numbers 2, 1, 2, 3, and 4, respectively.
Sample Output
2
0
2
1
3
OUTPUT DETAILS:
The first cow pats the second and third cows; the second cows pats no cows;
etc.
0
2
1
3
OUTPUT DETAILS:
The first cow pats the second and third cows; the second cows pats no cows;
etc.
HINT
Source
解题思路:统计每个数出现的次数,然后从1扫到最大的数,如果该数出现过,那么给它的倍数们加上贡献。
代码如下:
#include <cstdio>
#include <algorithm>
using namespace std;
int ans[1000010],num[100010],cnt[1000010];//cnt记录每个数出现的次数
int main()
{
int n,x;
scanf("%d",&n);
int mx=-1;//找出输入数的最大值
for(int i=0;i<n;i++)
{
scanf("%d",&num[i]);
cnt[num[i]]++;
mx=max(mx,num[i]);
}
for(int i=1;i<=mx;i++)
{
if(cnt[i]!=0)//如果i这个数出现过,那么统计它对它的倍数们所做的贡献
{
for(int j=i;j<=mx;j=j+i)
{
ans[j]=ans[j]+cnt[i];
}
}
}
for(int i=0;i<n;i++)
{
printf("%d\n",ans[num[i]]-1);//-1是减去自己 ,不拍自己的头
}
return 0;
}