I'll play a trick on you

I'll play a trick on you

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 1
描述
Please look the picture carefully. Then I'll give you two integers and your task is output the third one.
Please never doubt the picture.

输入
The first line is a number T(1<=T<=30), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers A,B (1<=B<=A<=10^100)
输出
For each case, output the number of case and the third integer.
样例输入
3
99 72
45 27
39 18
样例输出
27
18
21
来源
2011 Alibaba Programming Contest
上传者

李文鑫

以为傻傻认为是题出错了!原来是自己错了。99和72 是 9+9=18 7+2=9 ->18+9=27

 

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    int T,i,lenc,lend,sum;
	char c[200],d[200];
	scanf("%d",&T);
	while(T--)
	{	sum=0;
           cin>>c>>d;
		   lenc=strlen(c);
		   lend=strlen(d);
		  for(i=0;i<lenc;i++)
			  sum+=c[i]-'0';
		  for(i=0;i<lend;i++)
			  sum+=d[i]-'0';
          printf("%d\n",sum);
		}
	return 0;
}        

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
问题要求计算执行算法的迭代次数,直到能够恢复初始值。我们可以使用深度优先搜索(DFS)来解决这个问题。 中文解释: 1. 首先,我们创建一个数组`visited`,用于记录已经访问过的状态。 2. 然后,我们定义一个辅助函数`dfs`来执行深度优先搜索。这个函数有四个参数:当前状态`state`,初始状态`initial_state`,数组`a`和数组长度`n`。 3. 在`dfs`函数中,我们首先将当前状态添加到已访问集合中,并递归地遍历每个位置i。 4. 对于每个位置i,我们检查是否存在之前记录的状态,使得a等于初始状态的ai。如果存在,则继续递归地执行`dfs`函数。 5. 如果遍历完所有位置i后仍然没有找到满足条件的状态,则返回false。 6. 在主函数中,我们首先记录初始状态,然后调用`dfs`函数进行深度优先搜索,并返回迭代次数。 下面是对应的C++代码实现: ```cpp #include <iostream> #include <vector> int iterations = 0; bool dfs(std::vector<int>& state, std::vector<int>& initial_state, std::vector<int>& a, int n) { if (state == initial_state) { return true; } if (iterations > n) { return false; } iterations++; for (int i = 0; i < n; i++) { if (state[i] != a[i] && state[a[i] - 1] == a[i]) { std::swap(state[i], state[a[i] - 1]); if (dfs(state, initial_state, a, n)) { return true; } std::swap(state[i], state[a[i] - 1]); } } return false; } int main() { int n; std::cin >> n; std::vector<int> a(n); for (int i = 0; i < n; i++) { std::cin >> a[i]; } std::vector<int> state(a); std::vector<int> initial_state(a); iterations = 0; dfs(state, initial_state, a, n); std::cout << iterations << std::endl; return 0; } ``` 请注意,这只是一个基本的实现示例,并未进行错误处理和输入验证。在实际应用中,您可能需要根据实际情况进行更多的输入检查和错误处理。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值