NYOJ 400 I'll play a trick on you

I'll play a trick on you

时间限制: 3000  ms  |  内存限制: 65535  KB
难度: 1
描述
Please look the picture carefully. Then I'll give you two integers and your task is output the third one.
Please never doubt the picture.

输入
The first line is a number T(1<=T<=30), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers A,B (1<=B<=A<=10^100)
输出
For each case, output the number of case and the third integer.
样例输入
3
99 72
45 27
39 18
样例输出
27
18
21

 

思路:值的范围很大,所以必须用字符串来表示,图片找规律别找错了,因为21 - 13  != 7。其实就是数值的各个位相加的结果。

#include <stdio.h>

int main()
{
	int m;
	scanf("%d",&m);
	while (m--)
	{
		char a[110],b[110];
		int sum = 0,i;
		scanf("%s %s",a,b);
		for (i=0; a[i] != 0; i++)
		{
			sum += a[i] - '0';
		}
		for (i=0; b[i] != 0; i++)
		{
			sum += b[i] - '0';
		}
		printf("%d\n",sum);
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值