Play on Words

Play on Words

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6559 Accepted Submission(s): 2204


Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".

Sample Input
  
  
3 2 acm ibm 3 acm malform mouse 2 ok ok

Sample Output
  
  
The door cannot be opened. Ordering is possible. The door cannot be opened.

Source

参考网址:http://www.cnblogs.com/zhourongqing/archive/2012/07/10/2585235.html
 【引用】【题意:判断n个单词是否可以相连成一条链或一个环,两个单词可以相连的条件是 前一个单词的最后一个字母和后一个单词的第一个字母一样。
分析:有向图的欧拉回路判断
 链: 头 入度==出度-1 ;中间 入度==出度 ; 尾 入度==出度+1;
注:
欧拉回路的定义:图G的一个回路,若它恰通过G中每条边一次,则称该回路为欧拉(Euler)回路。
欧拉回路判断:判断基于此图的基图连通。
1、图存在欧拉回路的充要条件:一个无向图存在欧拉回路,当且仅当该图所有顶点度数都是偶数且该图是连通图。
2、图存在欧拉回路的充要条件:一个有向图存在欧拉回路,所有顶点的入度等于出度且该图是连通图。】
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int out[26],in[26],father[26],visited[26];
int find(int x)
{
    while(x!=father[x])
        x=father[x];
    return x;
}
void unionb(int x,int y)
{
    int xx,yy;
    xx=find(x);
    yy=find(y);
    if(xx!=yy)
        father[xx]=yy;
}

int main()
{
    int T,N,i,j,len,x,y,flag;
    char a[1001];
    cin>>T;
        while(T--)
        {
            flag=0;
            cin>>N;
        for(i=0;i<26;i++)
           father[i]=i;
       memset(in,0,sizeof(in));
       memset(out,0,sizeof(out));
       memset(visited,0,sizeof(visited));
       for(i=1;i<=N;i++)
       {
          cin>>a;
          len=strlen(a);
          x=a[0]-'a';
          y=a[len-1]-'a';
          out[x]++;
          in[y]++;
          unionb(x,y);
          visited[x]=visited[y]=true;
       }
       for(i=0;i<=25;i++)
       {
           int h;
           if(visited[i])
           {
               h=find(i);
              for(j=i+1;j<=25;j++)
              {
                  if(visited[j] && find(j)!=h)
                  {
                     cout<<"The door cannot be opened."<<endl;
                     flag=1;
                     break;
                  }
              }
              break;
           }  
       }
       if(flag==1)
           continue;
       int m,n,o;
       m=n=o=0;
        for(i=0;i<=25;i++)
        {
            if(visited[i] && (out[i]!=in[i]))
            {
                if(out[i]+1==in[i])
                    m++;
                else if(in[i]+1==out[i])
                    n++;
                else
                    o++;
            }
        }
        if((m==1&&n==1&&o==0)||(m==0 &&n==0&&o==0))
            cout<<"Ordering is possible."<<endl;
        else
            cout<<"The door cannot be opened."<<endl;

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值