记忆化深搜+dp

hdu  1078

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2840    Accepted Submission(s): 1105


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
  
  
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
  
  
37
 

每次能朝一个方向跑最多k格,然后格子里面的数必须递增,样例分析:1+2+5+6+11+12 = 37 
刚开始用DFS做TLE了,上网搜了代码,看了半天才弄懂,DP太弱,
因为是要求下一步必须比前一步的值大,所以吃过的不用做标记,下一次迟到的肯定不是上一次的
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=105;
int n,m,ans,k;
int map[maxn][maxn];
int dp[maxn][maxn];
// 存图
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
int dfs(int x,int y)
// 状态就是当前点的坐标
{
int max1=0;
if(dp[x][y]>0)
return dp[x][y];
for(int i=0;i<4;i++)
{
    int num=1;
for(num=1;num<=k;num++))//一次可以跳1-k步,k不中只吃到一次
{
    int nx=x+num*dir[i][0];
// 状态的扩展
int ny=y+num*dir[i][1];
if(nx>=1&&nx<=n&&ny>=1&&ny<=n&&map[x][y]<map[nx][ny])
//条件要求下一步必须比前一步的值大

{
    int ret=dfs(nx,ny);
     nx=nx+dir[i][0];
     ny=ny+dir[i][1];
     max1=max(max1,ret);
}
}
}
dp[x][y]=max1+map[x][y];//本身也要加上
//状态转移方程 DP[p][q]=max(dp[i][q],dp[p][j])+map[p][q]  其中i就是左右,j是上下
从四周找到最大的数,
return dp[x][y];
}
int main()
{
while(scanf("%d%d",&n,&k)!=EOF)
{
    if(n==-1&&k==-1)
    break;
int sx,sy;
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
{
cin>>map[i][j];
}
ans=0;
memset(dp,0,sizeof(dp));
ans=dfs(1,1);
printf("%d\n",ans);
//输出答案
}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值