DFS-POJ_Oil_Deposits(八连通)

Oil Deposits
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20290 Accepted: 10642

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

 
0
1
2
2
 

解题须知:八连通问题,八向连通八连通)区域指的是从区域内每一象素出发,可通过八个方向,即上、下、左、右、左上、右上、左下、右下这八个方向的移动的组合,在不越出区域的前提下,到达区域内的任意象素。

分析:本题目大意是给出一块区域,找出其中油田的区域数,其中两个相邻(这个相邻在平面上为上、下、左、右、左上、右上、左下、右下都相邻)的油田算作是同一个油田区域,所以这一个典型的八连通问题,解决这个问题就要使用到深搜算法找到所有的情况。针对本题目的解法为,遍历节点为‘@’位置,并将于‘@’相邻的位置变为‘.’即非油田,深搜的次数即为油田区域数。

import java.util.*;
public class POJ_Oil_Deposits {
	static int m,n;
	static int[][] area=new int[100][100];
	static int s[][]= {{-1,-1},{-1,0},{-1,1},{0,1},{1,1},{1,0},{1,-1},{0,-1}}; //右上、上、左上依次顺时针旋转每个位置坐标需要改变的值
	public static void dfs(int x,int y) {
		int dx,dy;
		area[x][y]='.';
		for(int i=0;i<8;i++) {
			dx=x+s[i][0];
			dy=y+s[i][1];
			if(dx>=0&&dx<n&&dy>=0&&dy<m&&area[dx][dy]=='@') {
				dfs(dx,dy);
			}
		}
	}
	public static int f() {
		int count=0;
		for(int i=0;i<n;i++) {
			for(int j=0;j<m;j++) {
				if(area[i][j]=='@') {
					dfs(i,j);
					count++;
				}
			}
		}
		return count;
	}
	public static void main(String[] args) {
		Scanner in=new Scanner(System.in);
		String s="";
		n=in.nextInt();
		m=in.nextInt();
		while(m!=0&&n!=0) {
			s=in.nextLine();
			for(int i=0;i<n;i++) {
				s=in.nextLine();
				for(int j=0;j<m;j++) {
					area[i][j]=s.charAt(j);
				}
			}
			System.out.println(f());
			n=in.nextInt();
			m=in.nextInt();
		}
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值