POJ 1562 Oil Deposits(DFS,八连通,连通分量)

Oil Deposits
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 16123 Accepted: 8707

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source



题意:

就是给我们一张地图,问我们有多少个连通区域,注意:这题的方向是八方向,和 POJ 2386 差不多,基本一样。


思路:

基础的 DFS ,这是自己做的第 4 个搜索类的题目,慢慢有了感觉,最起码比二分好多(其实,学长可能就没出难的 DFS 题目尴尬)了,当然也要积累解决题目的方法。


代码:

#include<stdio.h>
#include<string.h>
#define MYDD 1103

int m,n;
char map[128][128];//记录淹没的坐标点
int dx[]= {0,0,-1,1,1,1,-1,-1};//八连通的图了
int dy[]= {-1,1,0,0,-1,1,-1,1};//当前位置周围的八个方向

void DFS(int x,int y) {
	map[x][y]='*';//标记当前位置已经被访问
	for(int j=0; j<8; j++) {
		int gx=x+dx[j];
		int gy=y+dy[j];
		if(gx>=0&&gx<=m&&gy>=0&&gy<=n&&map[gx][gy]=='@') {
		//	map[gx][gy]='*';
			DFS(gx,gy);//满足条件继续查询 
		}
	}
	return ;
}

int main() {
	while(scanf("%d%d",&m,&n)&&(m||n)) {
		for(int j=0; j<m; j++)
			scanf("%s",map[j]);//键入地图
		int ans=0;
		for(int j=0; j<m; j++) {
			for(int k=0; k<n; k++) {
				if(map[j][k]=='@') {//搜索开始的条件 
					//sum=0;
					DFS(j,k);
					ans++;
				}
			}
		}

		printf("%d\n",ans);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值