原来这也叫做建树(利用数组的下标和值来建立关系网)

问题描述
Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is his elder, younger or brother.
输入
There are multiple test cases.
For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered 2.
Proceed to the end of file.
输出
For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly one line.
样例输入
5
1 3
2 4
3 5
4 6
5 6
6
1 3
2 4
3 5
4 6
5 7
6 7
样例输出
You are my elder
You are my brother
题目大意;就是输入几组父子的关系,求标号1与2是什么关系;同一代,年轻一代还是老一代;
训练赛的时候刚看这题目第一想法就是想建树来做;然后我不会;幸好队友用并查集ac了;
最后看了题解;才知道这是一道有点水的题;
还是言归正传吧;使用树来做吧;第一眼看到这代码是我真的一脸懵逼;
原来这就叫建树哈;都我呢???
就是用数组利用他们的值和下标来处理他们的关系;晕死了;;;
当然这也是一种好思维哈;并查集也是这样的利用数组的下标和值来建立关系网

//建树方法;
#include<stdio.h>
#include<string.h>
int shu[2005];
int main()
{
    int n, i, sum1,sum2,a,b;
    while(~scanf("%d",&n))
    {
        memset(shu,0,sizeof(shu));
        for(i = 0; i < n; i++)
        {
            scanf("%d %d",&a, &b);
            shu[a] = b;//儿子当下标,从下往上建;
        }
        sum1=sum2=0;
        for(i = 1; ; i = shu[i])
        {
            if(shu[i]!=0)
                sum1++;
            else break;
        }
        for(i = 2; ; i = shu[i])
        {
            if(shu[i]!=0)
                sum2++;
            else break;
        }
        if(sum1==sum2)
        {
            printf("You are my brother\n");
        }
        else if(sum1<sum2)
        {
            printf("You are my younger\n");
        }
        else
        {
            printf("You are my elder\n");
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值