HDOJ 1002 A + B Problem II(大数A+B)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 237322    Accepted Submission(s): 45702


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

解题方法:

             先将字符串反转存入整形数组,整形数组按位相加,若相加后大于十则前一位加一。相加结束后,

     倒叙逐个输出整形数组的每一位数。


注意:输出格式和南阳不一样,南洋的代码会PE.


AC代码如下:


#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int max(int x,int y)
{
	int z;
	z=x>y?x:y;//比较两个值大小 
	return z;
}

int main()
{
	int lena,lenb,i,n,t=0,z,numa[1100],numb[1100];
	char a[1100],b[1100];
	scanf("%d",&n);
	while(n--)
	{
		memset(numa,0,sizeof(numa));
		memset(numb,0,sizeof(numb));//int数组清零 
		scanf("%s%s",a,b);
		lena=strlen(a);
		lenb=strlen(b);
		for(i=0;i<lena;i++)
		   numa[lena-1-i]=a[i]-'0';
		for(i=0;i<lenb;i++)
		   numb[lenb-1-i]=b[i]-'0';
		z=max(lena,lenb);
		for(i=0;i<z;i++)//此处i值的范围就是两个字符串长度的最大者
		{
			numa[i]=numa[i]+numb[i];
			if(numa[i]>9)//处理相加大于十的情况
			{
				numa[i]=numa[i]-10;
				numa[i+1]++;
		    }
		}
		t++;
		printf("Case %d:\n",t);  
        printf("%s + %s = ",a,b);  
		if(numa[z]==0)// 判断数组第z位是否为零 
		{
			for(i=z-1;i>=0;i--)
			   printf("%d",numa[i]);
			printf("\n");
		}
		else
		{
			for(i=z;i>=0;i--)
			  printf("%d",numa[i]);
			printf("\n");
		}
		if(n!=0)//每一次的输入遇上一次的输出之间空一行 ,n=0是输出的是最后一组数据,即不用空出一行 
		  printf("\n");
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值