hdojA+BProblemII

A + B Problem II

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 6
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int main()
{
    int g,q,e,w,l,k,d[1100],a[1100],b[1100],i,j;
    char s[1100],c[1100];
    while(scanf("%d",&k)!=EOF){
                               g=1;
     while(k--){
     memset(a,0,sizeof(a));
     memset(b,0,sizeof(b));
     memset(d,0,sizeof(d));
    scanf("%s%s",s,c);
    l=strlen(s);
    j=strlen(c);
    e=1;w=1;
    for(i=l-1;i>=0;--i)
    a[e++]=s[i]-'0';
    for(i=j-1;i>=0;--i)
    b[w++]=c[i]-'0';
    q=0;
    for(i=1;i<=1100;++i){
    q=(a[i-1]+b[i-1]+q)/10;
     d[i]=(a[i]+b[i]+q)%10;}
     for(i=1100;i>=0;--i){
      if(d[i]!=0)
      break;}
      printf("Case %d:\n",g++);
      printf("%s + %s = ",s,c);
      for(j=i;j>=1;--j)
      printf("%d",d[j]);
       printf("\n");
       if(k!=0)//注意格式
       printf("\n");}}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值