NYOJ 271 The 3n + 1 problem

The 3n + 1 problem

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs. 
Consider the following algorithm: 
1.  input n
2.  print n
3.  if n = 1 then STOP
4.  if n is odd then   n <-- 3n+1
5.  else   n <-- n/2
6.  GOTO 2

Given the input 22, the following sequence of numbers will be 

printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 


It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 
输入
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0. 

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.
输出
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
样例输入
1 10
100 200
201 210
900 1000
样例输出
1 10 20
100 200 125
201 210 89
900 1000 174


  打表法,先把1到10000的数的计算次数打表出来,否则会超时,比较简单,代码如下:


#include<stdio.h>
int a[10010];

int num(int n)
{
	int i=1;
	while(n!=1)
	{
		if(n&1)
		   n=3*n+1;
		else 
		    n>>=1;
		i++;
	}
	return i;
}

void numlen()
{
	int i;
	for(i=1;i<10010;i++)
	   a[i]=num(i);
}

int main()
{
	numlen();
	int x,y,n,maxnum,min,max,i;
	while(scanf("%d%d",&x,&y)!=EOF)
	{
		maxnum=0;
		min=x<y?x:y;
		max=x>y?x:y;
		for(i=min;i<=max;i++)
		{
			n=a[i];
			if(n>maxnum)
			   maxnum=n;
		}
		printf("%d %d %d\n",x,y,maxnum);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值