HDOJ 1021 Fibonacci Again

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43372    Accepted Submission(s): 20712


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
 
解法一:同余定理,数列打表。
 
由于题中给出的数据较大,用数组储存会溢出,所以在打表时要用上同余定理。这个不多说,代码如下:
 
#include<stdio.h>
#define max 1000010
int a[max];
int main()
{
	int n,i;
	a[0]=7;a[1]=11;
	for(i=2;i<max;i++)
	   a[i]=((a[i-1]%3)+(a[i-2]%3))%3;//同余定理,防止数据溢出 
	while(scanf("%d",&n)!=EOF)
	{
		if(!a[n])
		   printf("yes\n");
		else
		   printf("no\n");
	}
	return 0;
} 

解法二:找规律。
 
数及对应的规律用(int型表示)
0 1  2  3  4  5  6   7  ......41                            42
 7 11 18 29 47 76 123 199......1568397607 负值(超出最大整数值,溢出)
数字规律
前几位数及其余数  
         0   1     2     3     4     5     6       7        8
数     7   11   18   29   47   76   123   199   322
余数  1   2     0     2     2     1      0      1       1
可知观察每四个为一组中第三个为yes即 i%4==2或(i-2)%4==0求即可
 
具体代码如下:
 
#include<stdio.h>
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		if(n%4==2)
		   printf("yes\n");
		else
		   printf("no\n");
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值