ZOJ 2100 Seeding(dfs)

Seeding

Time Limit: 2 Seconds      Memory Limit: 65536 KB

It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?


Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.


Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.


Sample Input

4 4
.S..
.S..
....
....
4 4
....
...S
....
...S
0 0


Sample Output

YES
NO

 

题意:有一片矩形农场,由N*M块方格组成的。S表示该格是一块石头,拖拉机的初始位置是在牧场的左上角,给字符串数组表示牧场,拖拉机播种时不能走到有石头的方格和已经播种了的方格,问拖拉机是否能播种完整片农场。

 

题解:将S的个数记录下来为count,遍历整片农场,记录下拖拉机能播种的田的数量sum,判断N*M-count是否等于sum即可。

 

代码如下:

 

#include<cstdio>
#include<cstring>
char map[8][8]; 
int n,m,count,sign,sum;

void dfs(int x,int y)
{
	if(x>0&&x<=n&&y>0&&y<=m&&map[x][y]=='.')
	{
		map[x][y]='S';
		sum++;
		if(sum==n*m-count)
		{
			sign=1;
			return ;
        }
		dfs(x+1,y);
		dfs(x-1,y);
		dfs(x,y-1);
		dfs(x,y+1);
		sum--;
		map[x][y]='.';
	}
}

int main()
{
	int i,j;
	while(scanf("%d%d",&n,&m)&&n||m)
	{
		sign=0;
		count=0;
		sum=0;
		for(i=1;i<=n;i++)
		{
			getchar();
			for(j=1;j<=m;j++)
			{
				scanf("%c",&map[i][j]);
				if(map[i][j]=='S')
				  count++;
			}
		}
		dfs(1,1);
		if(sign)
		   printf("YES\n");
		else
		   printf("NO\n");
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值