POJ 2406 Power Strings(KMP 找最短循环节)

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 37553 Accepted: 15526

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

 

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

 

Output

For each s you should print the largest n such that s = a^n for some string a.

 

Sample Input

abcd
aaaa
ababab
.

 

Sample Output

1
4
3

 

 

KMP好难有木有?QAQ。。。

 

根本不理解kmp啊,对着宇神的代码意淫了好几个小时才看得有一点点懂。这一个星期从递归回溯到KMP,越来越怀疑自己到底是不是弱智了。。。

 

多说是泪,代码如下:

 

#include<cstdio>
#include<cstring>
#define max 1000010
char p[max];
int f[max],len;
void kmp()
{
	int i=0,j=-1;
	f[0]=-1;
	while(i<len)
	{
		if(j==-1||p[i]==p[j])
		   f[++i]=++j;
		else
		   j=f[j];
	}
}

int main()
{
	while(scanf("%s",p)&&p[0]!='.')
	{
		len=strlen(p);
		kmp();
		if(len%(len-f[len]))//当找到的最小循环节的长度不能被原串长度整除,那这个循环节一定是伪循环节,在题目定义中不存在 
		    printf("1\n");//比如在串aabaabaabaa中查找到的最小循环节为3,但11并不能被整除3,输出结果为1Power Strings
		else
		   printf("%d\n",len/(len-f[len]));
	}
	return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值