POJ 2406 Power Strings KMP 求最小循环节

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 29027 Accepted: 12124

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source


给定一个字符串m,求一个最短的子串n,m是n重复多次组成的(求m的最小循环节)。

利用kmp中next(我的数组名是p)数组的性质。

表达能力拙计。。。分析样例的next数组找数学规律吧。

还有,用cin是可以AC的。

#include <iostream>
using namespace std;
string s;
int l,i,j,p[1000010];
int main()
{
	ios::sync_with_stdio(false);
	while (cin>>s && s!="."){
		l=s.size();
		j=-1; p[0]=-1;
		for (i=1;i<l;++i){
			while (j>-1 && s[i]!=s[j+1]) j=p[j];
			if (s[i]==s[j+1]) ++j;
			p[i]=j;
		}
		i=l-p[l-1]-1;
		if (l%i==0) cout<<l/i<<endl; 
		else cout<<"1\n";
	}
	return 0;
} 


kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值