HDOJ 1513 Palindrome(LCS+滚动数组)

Palindrome

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4113    Accepted Submission(s): 1405


Problem Description
A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.
 

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.
 

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.
 

Sample Input
  
  
5 Ab3bd
 

Sample Output
  
  
2
 

题意:向一个字符串中添加其本身的字符,最少添加几个能成为回文串。

解题思路:求出字符串的逆序串,找出逆序串与本串的最长公共子序列,即用原串的长度减去子串的长度,可得出需要添加的最小字符的个数。
 
注意,本题的字符串长度最大可达到5000,dp数组[5000][5000]会爆内存,所以用滚动数组dp[2][5050]。
 
代码如下:
 
<span style="font-size:12px;">#include<cstdio>
#include<cstring>
char str[5050],s[5050];
int dp[2][5050];

int max(int a,int b)
{
    return a>b?a:b;
}

int main()
{
    int n,i,j;
    while(scanf("%d",&n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        scanf("%s",str);
        for(i=0;i<n;++i)
            s[i]=str[n-1-i];
        for(i=1;i<=n;++i)
        {
            for(j=1;j<=n;++j)
            {
                if(str[i-1]==s[j-1])
                   dp[i%2][j]=dp[(i-1)%2][j-1]+1;
                else
                   dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
            }
        }
        printf("%d\n",n-dp[n%2][n]);
    }
    return 0;
} </span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值