HDOJ 5586 Sum(最大连续子序列和)



Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 44    Accepted Submission(s): 32


Problem Description
There is a number sequence A1,A2....An ,you can select a interval [l,r] or not,all the numbers Ai(lir) will become f(Ai) . f(x)=(1890x+143)mod10007 .After that,the sum of n numbers should be as much as possible.What is the maximum sum?
 

Input
There are multiple test cases.
First line of each case contains a single integer n.
(1n105)
Next line contains n integers
A1,A2....An . (0Ai104)
It's guaranteed that
n106 .
 

Output
For each test case,output the answer in a line.
 

Sample Input
  
  
2 10000 9999 5 1 9999 1 9999 1
 

Sample Output
  
  
19999 22033
 

Ai=f(Ai)-Ai,然后求一遍最大连续子序列和就能知道最多能增加的值。

上面是官方给出的题解, 题目和HDOJ  1003很像,1003就是一个最大连续子序列和的模板题。我没有求最大连续子序列,不过思想差不多。

代码如下:

#include<cstdio>
#include<cstring>
int a[100010];
int main()
{
	int n,i,start,end,temp,max,sum,ans;
	while(scanf("%d",&n)!=EOF)
	{
		sum=0;
		for(i=0;i<n;++i)
		{
			scanf("%d",&a[i]);
			sum+=a[i];
		}
	 	ans=sum; max=sum;
		for(i=0;i<n;++i)
		{
			ans=ans-a[i]+((1890*a[i]+143)%10007);
			if(ans>max)
				max=ans;
			if(ans<sum)
				ans=sum;
		}
		printf("%d\n",max);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值