POJ 2456 Aggressive cows(二分搜索,最大化最小值)

Aggressive cows

Time Limit: 1000MS


Memory Limit: 65536K

Total Submissions: 9062


Accepted: 4504

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.


题意:在有N间牛舍的小屋中,第i个牛舍在xi的位置上,农夫拥有的M头牛,彼此间会经常攻击。所以需要把每头牛都放在离其他牛尽可能远的牛舍。也就是要最大化最近的两头牛之间的距离。


题解:我们设d为最近两头牛之间的距离,按照题意我们要使d的值最大。可以使用二分搜索法。先对牛舍的位置x进行排序,把第一头牛放入x0的牛舍。如果第i头牛放入了xj中,第i+1头牛就要放入满足xj+d<=xk的最大的xk中。


代码如下:


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,a[100010];

bool dis(int d)
{
	int k=0,next,i;
	for(i=1;i<m;++i)
	{
		next=k+1;
		while(next<n&&a[next]-a[k]<d)
			next++;
		if(next==n)
			return false;
		k=next;	
	}
	return true;
}

int main()
{
	int i;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int INF=0;
		for(i=0;i<n;++i)
		{
			scanf("%d",&a[i]);
			if(INF<a[i])
				INF=a[i];
		}
		sort(a,a+n);
		int left=0,right=INF+1,mid;
		while(right-1>left)
		{
			mid=(left+right)/2;
			if(dis(mid))
				left=mid;
			else
				right=mid;
		}
		printf("%d\n",left);	
	}
	return 0;
} 





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值