poj 2456 Aggressive cows 【二分+最大化最小值】

题目链接:http://poj.org/problem?id=2456

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21009 Accepted: 9984

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

题意:n个个牛舍,每个牛舍在坐标轴上都有一个位置,农夫有m头牛,现在为了防止牛互相伤害,决定把每头牛都放在离其他牛尽可能远的牛舍。也就是要最大化最近的两头牛之间的距离。

分析:类似最大化最小值或者最小化最大值的问题,优先考虑二分搜索算法。我们不妨定义:

                 C(d):=可以安排牛的位置使得最近的两头牛的距离不小于d

这个时候问题就可以转化为求满足 C(d)的最大的d。另外,最近的间距不小于d也可以说成是所有牛的间距都不小于d,所有就有

               C(d)= 可以安排的牛的位置使得任意的牛的间距都不小于d

于是这个问题的判断使用贪心便可以求解:

\bullet 对牛舍的位置x进行排序

\bullet把第一头牛放入x_{0}的牛舍

\bullet如果第i头牛放入x_{j}的话,第i+1头牛就要放入满足x_{j}+d\leq x_{k} 的最小的x_{k}

每次判断对每头牛最多进行一次处理,复杂度就是O(n)

代码实现如下:

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
typedef long long ll;
const int maxn = 1e5+10;
const int inf = 0x3f3f3f3f;
ll a[maxn],m,n;
bool judge(int d) //贪心判断大法好
{
    int last = 0;
    for(int i=1;i<m;i++)
    {
        int last1 = last + 1;
        while(last1 < n && a[last1] - a[last] <d)
            last1 ++ ;
        if(last1 == n)
            return false;
        last = last1;
    }
    return true;
}
int main()
{
    ios::sync_with_stdio(false);
    cin>>n>>m;
    for(int i=0;i<n;i++)
        cin>>a[i];
    sort(a,a+n);
    int l=0,r=inf,mid;
    for(int i=1;i<100;i++) //100次的循环可以确保达到小数点后30的精度范围
    {
        mid = (l+r)/2;
        if(judge(mid))
            l = mid;
        else
            r = mid;
    }
    cout<<mid<<endl; //我一般为了保险都取mid,因为最后都能相近而且要么是l=mid,要么是r=mid
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值