POJ 3045 Cow Acrobats(思维)

Cow Acrobats

Time Limit: 1000MS


Memory Limit: 65536K

Total Submissions: 3639


Accepted: 1412

Description

Farmer John's N (1 <= N <= 50,000) cows (numbered 1..N) are planning to run away and join the circus. Their hoofed feet prevent them from tightrope walking and swinging from the trapeze (and their last attempt at firing a cow out of a cannon met with a dismal failure). Thus, they have decided to practice performing acrobatic stunts. 

The cows aren't terribly creative and have only come up with one acrobatic stunt: standing on top of each other to form a vertical stack of some height. The cows are trying to figure out the order in which they should arrange themselves ithin this stack. 

Each of the N cows has an associated weight (1 <= W_i <= 10,000) and strength (1 <= S_i <= 1,000,000,000). The risk of a cow collapsing is equal to the combined weight of all cows on top of her (not including her own weight, of course) minus her strength (so that a stronger cow has a lower risk). Your task is to determine an ordering of the cows that minimizes the greatest risk of collapse for any of the cows.

Input

* Line 1: A single line with the integer N. 

* Lines 2..N+1: Line i+1 describes cow i with two space-separated integers, W_i and S_i. 

Output

* Line 1: A single integer, giving the largest risk of all the cows in any optimal ordering that minimizes the risk.

Sample Input

3
10 3
2 5
3 3

Sample Output

2

Hint

OUTPUT DETAILS: 

Put the cow with weight 10 on the bottom. She will carry the other two cows, so the risk of her collapsing is 2+3-3=2. The other cows have lower risk of collapsing.



题意:n头牛叠起来(一头牛站在另一头牛的上面,成“1”字形),每头牛都有自己的重量wi和力量si,每头牛都有风险值为自己上面的牛的总重减去自己的力量,问这n头牛叠起来面临的危险值最小是多少?


题解:对于这题有两种思路。


1:对于每头牛而言,视他与他上面的牛为一个整体,总重为sum_w,那么对于这头牛的危险值为sum_w-w-s,要想sum_w-(w+s)的值最小,w+s的值就应该最大,由此可见取最优化,wi+si越大越应该在下面。


2:假设目前排放的的序列是最优排列。任意位置有第一头牛和第二头牛分别有w1,s1;w2,s2。第一头牛上面的牛的重量总和为sum。且第一头牛在第二头牛上面,可以知道危险指数分别为a=sum-s1,b=sum+w1-s2。现在调换两头牛的位置,可得a'=sum+w2-s1,b'=sum-s2。  因为之前是最优排列,所以得知w2-s1>=w1-s2,   移项可得:

w2+s2>=w1+s1,所以体重和力量之和越大越在底下。


代码如下:


#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f
using namespace std;

struct node
{
	int w,s;
}a[50010];

int cmp(node a,node b)
{
	return a.w+a.s>b.w+b.s;
}

int main()
{
	int n,i,j;
	long long sum;
	while(scanf("%d",&n)!=EOF)
	{
		sum=0;
		for(i=0;i<n;++i)
		{
			scanf("%d%d",&a[i].w,&a[i].s);
			sum+=a[i].w;
		}
		sort(a,a+n,cmp);
		long long ans=-INF;
		for(i=0;i<n;++i)
		{
			sum-=a[i].w;
			ans=max(ans,sum-a[i].s);
		}
		printf("%lld\n",ans);
	}
	return 0;
} 



  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值