POJ 2718 Smallest Difference(贪心 or next_permutation()暴力枚举)

Smallest Difference

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 6524

 

Accepted: 1777

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0. 

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1
0 1 2 4 6 7

Sample Output

28

 

 

题意:给出一个集合,集合里是按升序排列的个位数,且不重复。用这些集合中的数组成两个数(集合中的每个数都只能用一次),求这两个数的最小差值是多少?

 

题解:分情况讨论一下:

1.当集合中的数有奇数个时,大的那个数多一位,要尽可能小,小的那个数要尽可能大。

 

2.当集合中的数有偶数个时,取靠得最近且最小的一对数分别为两个数的开头,开头大的那个数,后面要尽可能小,开头小的那个数,后面要尽可能大。

 

所以很明显,这一题是可以用贪心法解决的,模拟一下上面的思路即可,这里就不给出代码了。

 

觉得模拟很麻烦,就掏出了STL神器,暴力枚举所有符合要求的情况,记录下最小差值即可。

 

代码如下:

 

 

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
char str[30];
int num[15];
int main()
{
	int t,len,i,k;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		gets(str);
		len=strlen(str);
		k=0;
		for(i=0;i<len;++i)
		{
			if(str[i]>='0'&&str[i]<='9')
				num[k++]=str[i]-'0';	
		}
		if(k==2)//处理只有两个数的情况 
		{
			printf("%d\n",num[1]-num[0]);
			continue;
		}
		while(num[0]==0)//第一个数不能以零开头 
			next_permutation(num,num+k);
		int ans=999999999;
		do
		{
			int mid=(k+1)/2;
			if(num[mid])//第二个数不能以零开头 
			{
				int a=0,b=0;
				for(i=0;i<mid;++i)
					a=a*10+num[i];
				for(i=mid;i<k;++i)
					b=b*10+num[i];
				ans=min(ans,abs(a-b));
			}
		}while(next_permutation(num,num+k));
		printf("%d\n",ans);
	}
	return 0;
}

 

 

 

 



评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值