Stripies
Time Limit: 1000MS |
| Memory Limit: 30000K |
Total Submissions: 14071 |
| Accepted: 6590 |
Description
Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.
Input
The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.
Output
The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.
Sample Input
3
72
30
50
Sample Output
120.000
题意:介绍了一大堆,全废话。 题目就是说有n个物品,每个物品重w_i,对于两个物品他们合并时重量就会变成
w = 2 * sqrt(w_a * w_b)。 问当n个物品合成一个时,最小重量是多少?
题解:贪心啊,不过要用到一点数学知识,在n个物品中取两个物品合并,要想最后总重最小,要每次取两个重量最大的物品。关于这个结论,下面给出证明:
设:n=3,三个物品的重量分比为:a,b,c, 合并之后最小重量为w。
则w = 2 * sqrt( a* 2 * sqrt(b * c) )
化简后的 w^2/8 = sqrt( a*a*b*c ), 此式可得 a 取最小时 w 的值最小。
归纳总结,n个物品每次取最大的两个合并,总重最小。
代码如下:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;
int main()
{
int n;
double num;
while(scanf("%d",&n)!=EOF)
{
priority_queue<double>q;
while(n--)
{
scanf("%lf",&num);
q.push(num);
}
double ans=q.top();//注意n为1的情况
while(q.size()>1)
{
double a=q.top();
q.pop();
double b=q.top();
q.pop();
ans=2*sqrt(a*b);
q.push(ans);
}
printf("%.3f\n",ans);
}
return 0;
}