POJ 3046 Ant Counting(dp—多重集组合数问题)


Ant Counting

Time Limit: 1000MS


Memory Limit: 65536K

Total Submissions: 3753


Accepted: 1475

Description

Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants! 

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants. 

How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed? 

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were: 

3 sets with 1 ant: {1} {2} {3} 
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3} 
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3} 
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3} 
1 set with 5 ants: {1,1,2,2,3} 

Your job is to count the number of possible sets of ants given the data above. 

Input

* Line 1: 4 space-separated integers: T, A, S, and B 

* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive

Output

* Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.

Sample Input

3 5 2 3
1
2
2
1
3

Sample Output

10

Hint

INPUT DETAILS: 

Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made? 


OUTPUT DETAILS: 

5 sets of ants with two members; 5 more sets of ants with three members


题意:有n中蚂蚁,第i种蚂蚁有N_i个,一共有A个蚂蚁。不同类别的蚂蚁可以相互区分,但同种类别的蚂蚁不能相互区别。从这些蚂蚁中分别取出S,S+1...B个,一共有多少种取法。(解释不清楚,请看题中的Hint)

题解:dp问题,解释不清楚,请看《挑战》P68~P69的多重集组合数。我也是用的那里的模板,真心不太懂。

代码如下:

#include<cstdio>
#include<cstring>
#define mod 1000000
int a[1010];
int dp[1010][100010];//从前i种蚂蚁中取出j个的组合总数 
int main()
{
	int t,n,s,b,i,j,x;
	while(scanf("%d%d%d%d",&t,&n,&s,&b)!=EOF)
	{
		memset(a,0,sizeof(a));
		for(i=0;i<n;++i)
		{
			scanf("%d",&x);
			a[x-1]++;//方便运算,将蚂蚁编号从0计起 
		}
		for(i=0;i<=t;++i)//一个都不取的方法只有一种 
			dp[i][0]=1;
		for(i=1;i<=t;++i)
		{
			for(j=1;j<=b;++j)
			{
				if(j-1-a[i-1]>=0)//避免运算结果中出现负数 
					dp[i][j]=(dp[i][j-1]+dp[i-1][j]-dp[i-1][j-1-a[i-1]]+mod)%mod;
				else
					dp[i][j]=(dp[i][j-1]+dp[i-1][j])%mod;
			}
		}
		int ans=0;
		for(i=s;i<=b;++i)
			ans=(ans+dp[t][i])%mod;
		printf("%d\n",ans);
	}
	return 0;
} 

  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值