POJ 3320 Jessica's Reading Problem(尺取法)

Jessica's Reading Problem

Time Limit: 1000MS


Memory Limit: 65536K

Total Submissions: 9137


Accepted: 2952

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2


题意:为了准备考试,Jessica开始读一本很厚的课本。要想通过考试,必须要课本上每个知识点看一遍。这本书一共有P页,第i页恰好有一个知识点ai(每个知识点都有一个编号),同一个知识点可能被多页反复提到。所以她想阅读连续的一些页把书本中所有的知识点全覆盖到。给定每页写到的知识点,求出阅读的最少页数。


题解:我们假设从某一页s开始到t页能覆盖所有知识点,这样的话从s+1开始,必须阅读到t'(t'>=t)为止。由此我们可以用尺取法解决问题。

所有知识点被覆盖 ==== 每个知识点出现的次数大于等于1。

则我们在尺取法过程中记录下每个知识点出现的次数,从区间头部把s取出时,则s对应的知识点出现的次数减1,如果此时某个知识点出现的次数为0时,则将尾部t向后推进,直到再次覆盖住所有知识点。记录每次t-s的最小值,不断更新即可。 

此算法的时间复杂度为O(PlogP)。

代码如下:


#include<cstdio>
#include<algorithm>
#include<set>
#include<map>
using namespace std;
int a[1000010];
int main()
{
	int P,i,n;
	while(scanf("%d",&P)!=EOF)
	{
		set<int>s;
		for(i=0;i<P;++i)
		{
			scanf("%d",&a[i]);
			s.insert(a[i]);
		}
		n=s.size();//记录知识点的个数 
		int start=0,end=0,num=0,ans=P;
		map<int,int>mp;//对应每个知识点出现的次数 
		while(1)
		{
			while(end<P&&num<n)
			{
				if(mp[a[end]]==0)
					num++;
				mp[a[end]]++;
				end++;
			}
			if(num<n)
				break;
			ans=min(ans,end-start);
			if(--mp[a[start]]==0)//有一个知识点出现的次数为0了,就是减少了一个知识点 
				num--;
			start++;
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值