POJ 3684 Physics Experiment(弹性碰撞)

Physics Experiment
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1528 Accepted: 521 Special Judge

Description

Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).

Simon wants to know where are the N balls after T seconds. Can you help him?

In this problem, you can assume that the gravity is constant: g = 10 m/s2.

Input

The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers NHRT.
1≤ N ≤ 100.
1≤ H ≤ 10000
1≤ R ≤ 100
1≤ T ≤ 10000

Output

For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

Sample Input

2
1 10 10 100
2 10 10 100

Sample Output

4.95
4.95 10.20


题意:在H米高处设置一个圆筒,里面有n个半径为R的球(第i个球距离地面H+2*(i-1)*R)。 第0秒时,最下面的求开始下落,此后每一秒有一个球下落。不计空气阻力,球与球之间,球与地面之间的弹撞是弹性碰撞。 问经过T秒后,每个球底端距地面的高度?按顺序输出。


题解:当只有一个球时,这就是单纯的物理问题。 我们要考虑的是多个球的情况。所有的球都是一样的,球a与球b碰撞后,a与b交换速度,我们就可以无视他们之间的碰撞,视为直接互相穿过继续运动。 碰撞时球的顺序是不会改变的,先落下的球始终在下面。 所以将计算出的每个球的高度进行排序就能知道每个球的最终位置。

相关问题: POJ1852Ants  


代码如下:(狗逼的精度卡得我不要不要的)┭┮﹏┭┮


#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
double hi[110],g=10.0,t,H,R,T;
int n; 

double calc(double Ti)
{
	if(Ti<0)//球未释放 
		return H;
	int k=(int)(Ti/t);
	if(k%2==0)//k为偶数是下降的过程 
	{
		double d=Ti-k*t;
		return H-g*d*d/2;
	}
	else//k为奇数是碰撞到地面上升的过程 
	{
		double d=k*t+t-Ti;
		return H-g*d*d/2;
	}
}

int main()
{
	int C,i;
	scanf("%d",&C);
	while(C--)
	{
		scanf("%d%lf%lf%lf",&n,&H,&R,&T);
		t=sqrt(2*H/g);
		for(i=0;i<n;++i)
		{
			hi[i]=calc(T-i);
		}
		sort(hi,hi+n);
		for(i=0;i<n-1;++i)
			printf("%.2f ",hi[i]+2*R*i/100.0);//注意球的半径给出的是厘米单位 
		printf("%.2f\n",hi[n-1]+2*R*(n-1)/100.0);
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值