POJ:3684-Physics Experiment(弹性碰撞)

Physics Experiment

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3392 Accepted: 1177 Special Judge

Description

Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).
这里写图片描述
Simon wants to know where are the N balls after T seconds. Can you help him?

In this problem, you can assume that the gravity is constant: g = 10 m/s2.

Input

The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers N, H, R, T.
1≤ N ≤ 100.
1≤ H ≤ 10000
1≤ R ≤ 100
1≤ T ≤ 10000

Output

For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

Sample Input

2
1 10 10 100
2 10 10 100

Sample Output

4.95
4.95 10.20


解题心得:

  1. 题意就是有很多个小球从高度为H的平面向地面做自由落体运动,每隔1秒钟掉下一个小球,如果小球在空中碰撞了,那么两个小球直接交换速度(包括大小和方向)。
  2. 一看这个题第一个反应就是蚂蚁走线的问题,这个题和蚂蚁走线有很多的相同之处,两个小球相撞可以看成两个小球直接从对方的身体中穿过去了,因为速度交换就可以看做速度没变。但是有一个问题就是小球有半径,两个球碰撞的地方并不是圆心,而是下面小球的上方,上面小球的下方,其实就多了一个2r,下面有一个小球就多一个2r,所以在最后计算结果的时候加一个2r×i就行了。一个小小的坑点就是r单位是cm,高度是m。剩下的就是考的高中的自由落体知识。

#include <algorithm>
#include <stdio.h>
#include <math.h>

using namespace std;
const int maxn = 110;
const double g = 10.0;

double H[maxn];
int n, h, r, t, c;

void init() {
    scanf("%d%d%d%d", &n, &h, &r, &t);
}

double cal(double times) {
    if (times <= 0)
        return h;
    double T = sqrt(2.0 * (double) h / 10.0);
    int k = (int) (times / T);
    if (k & 1)//注意自由落体的计算公式
        return (double) h - g * ((double) k * T + T - times) * ((double) k * T + T - times) / 2.0;
    return (double) h - g * (times - (double) k * T) * (times - (double) k * T) / 2.0;
}

int main() {
    scanf("%d", &c);
    while (c--) {
        init();
        for (int i = 0; i < n; i++)
            H[i] = cal(t - i);
        sort(H,H+n);
        for (int i = 0; i < n; i++)
            printf("%.2f%c", H[i] + 2.0 * r * i / 100.0, i == n - 1 ? '\n' : ' ');
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值