HDOJ 5672 String

String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 965    Accepted Submission(s): 313


Problem Description
There is a string S . S only contain lower case English character. (10length(S)1,000,000)
How many substrings there are that contain at least k(1k26) distinct characters?
 

Input
There are multiple test cases. The first line of input contains an integer T(1T10) indicating the number of test cases. For each test case:

The first line contains string S .
The second line contains a integer k(1k26) .
 

Output
For each test case, output the number of substrings that contain at least k dictinct characters.
 

Sample Input
  
  
2 abcabcabca 4 abcabcabcabc 3
 

Sample Output
  
  
0 55
 

中文题面: BC Round #81 (div.2)1003  


题解:额,组合数学和模拟被学弟吊打(;′⌒`)  /(ㄒoㄒ)/~~  想多了,还以为这一题要DP计数,感觉不会搞。 学弟直接模拟计数。我这组合数学太渣渣。。。 
 
按顺序遍历字符串,记录出现的不同字母的个数cnt,和每种字母出现的数量。 当cnt==k时,以当前字符串为子串的子串共有len-i个。然后将最左边的减去,依次记录下去。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[1000010];
int num[30];
int main()
{
	int k,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s%d",s,&k);
		int len=strlen(s);
		int cnt=0,left=0;
		long long ans=0;
		memset(num,0,sizeof(num));
		for(int i=0;i<len;++i)
		{
			int temp=s[i]-'a';
			if(num[temp])
				num[temp]++;
			else
			{
				num[temp]++;
				cnt++;
			}
			if(cnt==k)
			{
				ans+=(len-i);
				while(1)
				{
					temp=s[left]-'a';
					num[temp]--;
					left++;
					if(!num[temp])
					{
						cnt--;
						break;
					}
					else
						ans+=(len-i);
				}
			}
		}
		printf("%I64d\n",ans);
	}
	return 0;
} 

   
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值