HDOJ 2669 Romantic(exgcd裸题)

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5165    Accepted Submission(s): 2163


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
 

Sample Input
  
  
77 51 10 44 34 79
 

Sample Output
  
  
2 -3 sorry 7 -3
 

题意:给出非负整数a,b;求的满足a*x+b*y=1的非负整数x和整数y,若没有则输出sorry

题解:今天重新看了扩展欧几里德,基本是懂了,半年前就看过了,一直不懂,智商啄鸡....

x与y解的通项式:   x=x 0 +(b/gcd)*k      y=y 0 -(a/gcd)*k  (k为正整数,gcd为gcd(a,b) )
证明见刘汝佳紫书P.313

裸题,不赘述。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long 

void exgcd(LL a,LL b,LL &d,LL &x,LL &y)
{
	if(b==0)
	{
		x=1;
		y=0;
		d=a;
		return ;
	}
	else
	{
		exgcd(b,a%b,d,y,x);
		y-=(a/b)*x;
	}
}

int main()
{
	LL a,b,d,x,y;
	while(scanf("%lld%lld",&a,&b)!=EOF)
	{
		exgcd(a,b,d,x,y);
		if(d!=1)
			printf("sorry\n");
		else{
			x=x%b;
			if(x<=0)
				x+=b;
			printf("%lld %lld\n",x,(1-x*a)/b);
		}
	}
	return 0; 
} 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值