HDOJ 5904 LCIS

LCIS

                                                              Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 588    Accepted Submission(s): 268

Problem Description
Alex has two sequences  a1,a2,...,an  and  b1,b2,...,bm . He wants find a longest common subsequence that consists of consecutive values in increasing order.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first line contains two integers  n  and  m   (1n,m100000)  -- the length of two sequences. The second line contains  n  integers:  a1,a2,...,an   (1ai106) . The third line contains  n  integers:  b1,b2,...,bm   (1bi106) .

There are at most  1000  test cases and the sum of  n  and  m  does not exceed  2×106 .
 

Output
For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.
 

Sample Input
  
  
3 3 3 1 2 3 3 2 1 10 5 1 23 2 32 4 3 4 5 6 1 1 2 3 4 5 1 1 2 1
 

Sample Output
  
  
1 5 0
 


题意:有两个序列,a1,a2,a2.....an和b1,b2,b3....bm。 找出他们的最长公共递增子序列,并且这个子序列的值是连续的(x,x+1,...,y-1,yx,x+1,...,y−1,y). 输出这个序列的长度。


题解:简单脑洞题。


代码如下:


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 100010
#define maxm 1000010
int a[maxn],b[maxn];
int fa[maxm],fb[maxm],sa[maxm],sb[maxn]; 
int main()
{
	int t,n,m,i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=1;i<maxn;++i)//memset无情超时,for循环险过 
		{
			fa[i]=0; fb[i]=0;
			sa[i]=0; sb[i]=0;
		}
		for(i=0;i<n;++i)
		{
			scanf("%d",&a[i]);
			fa[a[i]]=1;
		}	
		for(i=0;i<m;++i)
		{
			scanf("%d",&b[i]);
			fb[b[i]]=1;
		}
		for(i=0;i<n;++i)
			sa[a[i]]=sa[a[i]-1]+1;
		for(i=0;i<m;++i)
			sb[b[i]]=sb[b[i]-1]+1;
		int ans=0;
		for(i=1;i<=1e6;++i)
		{
			if(fa[i]&&fb[i])
				ans=max(ans,min(sa[i],sb[i]));
		}
		printf("%d\n",ans);
	}
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值