HDOJ 5918 Sequence I(KMP)

Sequence I

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
 Total Submission(s): 465    Accepted Submission(s): 180


Problem Description
Mr. Frog has two sequences  a1,a2,,an  and  b1,b2,,bm  and a number p. He wants to know the number of positions q such that sequence  b1,b2,,bm  is exactly the sequence  aq,aq+p,aq+2p,,aq+(m1)p  where  q+(m1)pn  and  q1 .
 

Input
The first line contains only one integer  T100 , which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers  1n106,1m106  and  1p106 .

The second line contains n integers  a1,a2,,an(1ai109) .

the third line contains m integers  b1,b2,,bm(1bi109) .
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
 

Sample Input
  
  
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
 

Sample Output
  
  
Case #1: 2 Case #2: 1
 

题意:有两个序列,a1~an与b1~bm。 给出p,问在a1~an中有几个q能满足  b1==aq  b2==bq+p  b3==bq+2p  

bm==aq+(m-1)p  ?


题解:典型的模式串匹配问题,和kmp模板不同的地方就是每隔p个距离查找一次, 而然要查找出所有满足条件的模式串, 就要进行p次匹配。  例如第一次匹配为  1 ,1+p, 1+2*p.....    第二次匹配为  2, 2+p, 2+2*p....  第p次匹配就是 p, 2*p, 3*p .....


代码如下:


#include<cstdio>
#include<cstring>
using namespace std;
const int N=1e6+5;
int n,m,p,next[N],a[N],b[N];
void getnext()
{
    int i=0,j=-1;
    next[i]=j;
    while(i<m)
    {
        if(j==-1||b[i]==b[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }
}
int kmp()
{
    int res=0;
    getnext();
    for(int k=0;k<p;++k){//进行p次匹配 
        int i=k,j=0;
        while(i<n)
        {
            if(j==-1||a[i]==b[j])
            {
                i+=p;//在母串上每隔p个位置匹配一次 
                j++;
                if(j==m)
                	res++;
            }
            else
                j=next[j];
        }
    }
    return res;
}
int main()
{
    int T;
    scanf("%d",&T);
    for(int kase=1;kase<=T;kase++)
    {
        scanf("%d%d%d",&n,&m,&p);
        memset(next,0,sizeof(next));
        memset(b,0,sizeof(b));//注意要清空b数组,这里WA了两发,迷之耽误一个小时 
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)scanf("%d",&a[i]);
        for(int i=0;i<m;i++)scanf("%d",&b[i]);
        printf("Case #%d: %d\n",kase,kmp());
    }
    return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值