UVA -刽子手游戏 —489

In “Hangman Judge,”

you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

1. The contestant tries to solve to puzzle by guessing one letter at a time.

2. Every time a guess is correct, all the characters in the word that match the guess will be “turned over.” For example, if your guess is ‘o’ and the word is “book”, then both ‘o’s in the solution will be counted as “solved”.

3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

______

    |    |

    |   O

    |   /|\

    |    |

    |   / \

__|_

|     |______

|_________|

4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.

5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.

6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out. Your task as the “Hangman Judge” is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of ‘-1’ would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.

You lose.

You chickened out.

Sample Input

1

cheese

chese

2 cheese

abcdefg

3

cheese

abcdefgij

-1

Sample Output

Round 1

You win.

Round 2

You chickened out.

Round 3

You lose.

在《刽子手法官》中

你要写一个程序来判断一系列刽子手游戏。对于每一个游戏,谜题的答案以及猜测。规则与刽子手的经典游戏相同,并给出如下:

1。参赛者试图通过一次猜一个字母来解决谜题。

2。每一次猜测都是正确的,与猜测相符的单词中的所有字符都将被“翻转”。例如,如果你的猜测是“O”,单词是“书”,那么解中的“O”都将被算作“解决”。

三。每次做出错误的猜测时,一个笔画将被添加到一个刽子手的图中,需要7个笔画才能完成。每个独特的错误猜测只对参赛者计数一次。

第二章

βi

γo

α/ε

βi

α\/\

α

β1

α,α,β,β,β

4。如果在选手成功猜出单词的所有字符之前完成了刽子手的绘制,参赛者就输了。

5。如果参赛者在绘画完成之前猜出了单词的所有字符,参赛者就赢了这场比赛。

6。如果参赛者猜不到足够的字母来赢或输,参赛者就会退缩。你作为“刽子手裁判员”的任务是确定每一场比赛,参赛者是否获胜、失利或无法完成比赛。

输入

你的程序将被给予一系列关于游戏状态的输入。所有输入将在小写。每个区段的第一行将包含一个数字以指示正在玩哪个回合;下一行将是解谜的解决方案;最后一行是由参赛者作出的猜测序列。“1”的整数表示所有游戏的结束(和输入)。

产量

你的节目的输出是为了指示参赛者现在正在玩哪一轮比赛以及比赛的结果。有三种可能的结果:

You win.

You lose.

You chickened out.

Sample Input

1

cheese

chese

2 cheese

abcdefg

3

cheese

abcdefgij

-1

Sample Output

Round 1

You win.

Round 2

#include<stdio.h>
#include<string.h>
const int N = 100;
int left,chance;
char s[N],s2[N];
int win , lose;
void guess(char ch){
	int bad = 1;
	for(int i = 0; i < strlen(s) ; i++){
		if(s[i] == ch){
			left--; s[i] = ' '; bad=0;
		}
	}
	if(bad) --chance;
	if(!chance) lose = 1;
	if(!left) win = 1;
}
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		if(n==-1) break;
		printf("Round %d\n",n);
		scanf("%s%s",s,s2);
		win = lose =0;
		left = strlen(s);
		chance = 7;
		for(int i=0; i<strlen(s2);i++){
			guess(s2[i]);
			if(win || lose) break;
		}
		if(win) printf("You win.\n");
		else if(lose) printf("You lose.\n");
		else printf("You chickened out.\n");
	}
}

You chickened out.

Round 3

You lose.

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值