刽子手游戏——Uva 489

In “Hangman Judge,” you are to write a program that judges a series of Hangman games. For eachgame, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic gameof hangman, and are given as follows:

  1. The contestant tries to solve to puzzle by guessing one letter at a time.

  2. Every time a guess is correct, all the characters in the word that match the guess will be “turnedover.” For example, if your guess is ‘o’ and the word is “book”, then both ‘o’s in the solution willbe counted as “solved”.

  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, whichneeds 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

    If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.

  4. If the contestant has guessed all the characters of the word before the drawing is complete, thecontestant wins the game.

  5. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the “Hangman Judge” is to determine, for each game, whether the contestant wins,loses, or fails to nish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lowercase. The rst line of each section will contain a number to indicate which round of the game is beingplayed; the next line will be the solution to the puzzle; the last line is a sequence of the guesses madeby the contestant. A round number of ‘-1’ would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playingas well as the result of the game. There are three possible results:

You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3 
You lose. 

评价:

    这道题不算是难题,就是在于条理清晰,自顶向下逐步求精。然而手生了所以说还是WAWAWA......

    主要的坑点有:1、猜过的字母再猜一次就算错...(由这个我想到了可以借助数组计数的方法,记下solution中的所有字符出现的次数,然后通过guess的每一个字符进行匹配比较遍历。如果当前字符猜对了那么就把当前的字符所在的个数清零。)2、可能会出现这样的情况,就是一个长长的字符串,虽然猜错的字符很多,但是在猜错的字符满足7个之前就已经猜对了。这种也算的。(怀疑这可能是我WA的原因。。。)


贴上书本的标准答案:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
#define maxn 110

int le, chance;
char s[maxn], s2[maxn];
int win, lose;//win = 1表示已经赢了,lose = 1表示已经输了

void guess(char ch)
{
    int bad = 1;
    for(int i = 0; i < strlen(s); i++)
        if(s[i] == ch)
        {
            le--;
            s[i] = ' ';
            bad = 0;
        }
    if(bad)
        --chance;
    if(!chance)
        lose = 1;
    if(!le)
        win = 1;
}

int main()
{
    int rnd;
    while(cin>>rnd && rnd != -1)
    {
        cin>>s>>s2;
        printf("Round %d\n", rnd);
        win = lose = 0;//求解一组新数据之前需要初始化
        le = strlen(s);
        chance = 7;
        for(int i = 0; i < strlen(s2); i++)
        {
            guess(s2[i]);//猜一个字母
            if(win || lose)
                break;//检查状态
        }
        //根据结果进行输出
        if(win)
            printf("You win.\n");
        else if(lose)
            printf("You lose.\n");
        else 
            printf("You chickened out.\n");
    }
    return 0;
}

我自己写的暂时还没有AC......A了之后贴上来......

A了之后的代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
string ans[3] = {"You win.", "You lose.", "You chickened out."};

int main(){
    int round;
    string solu, gues;
    while(cin>>round && round != -1)
    {
        cin>>solu>>gues;
        int cs[26] = {0};
        int cw = 0;
        int cc = 0;
        int cnt = 0;
        cout << "Round " << round << endl;
        int flag = 0;
        for(int j = 0; j < solu.size(); j++)
        {
            if(cs[solu[j] - 'a'] == 0)
                cnt++;
            cs[solu[j] - 'a']++;
        }
        for(int i = 0; i < gues.size(); i++)
        {
            if(cs[gues[i] - 'a'] == 0)
                cw++;
            else 
            {
                cs[gues[i] - 'a'] = 0;
                cc++;
            }
            if(cw >= 7)
            {
                cout << ans[1] << endl;
                flag = 1;
                break;
            }
            else if(cc == cnt)
            {
                cout << ans[0] << endl;
                flag = 1;
                break;
            }
            
        }
        if(!flag)
            cout<<ans[2]<<endl;
    }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值