dp让宝宝疯掉

本文深入探讨了信息技术领域的关键组件和技术应用,包括前端开发、后端开发、移动开发、游戏开发、大数据开发、开发工具等。通过具体实例阐述了如何在不同场景下运用这些技术和组件,为读者提供了一套全面的技术解决方案。
摘要由CSDN通过智能技术生成
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.<br>
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).<br>
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.<br>
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 
  
  

这个题

前面好逑 很简单的 dp 三角模型

找到 每个位置的最大值

就是最后的 位置

一直不知道哪里 wrong

实在找不到错误。

按照窦窦的错误来了

我的

#include<iostream> #include<string.h> #include<set> #include<stdio.h> #include<vector> #include<algorithm> #include<numeric> #include<math.h> #include <iostream> #include<stdio.h> #include<algorithm> #include<string.h> using namespace std; int main() {   int t;     int n;     int pao[100000];     int sum[100000];     int max[100000];     cin>>t;     int i;     int j=1;     int x1,x2;     while(t--)     {         cin>>n;         memset(pao,0,sizeof(pao));         memset(sum,0,sizeof(sum));         memset(max,0,sizeof(max));         x1=1;         x2=1;        long long int max2=pao[1];         for(i=1;i<=n;i++)         {             cin>>pao[i];         }         for(i=1;i<=n;i++)         {             if(max[i-1]+pao[i]<pao[i])             {                 max[i]=pao[i];                 if(max2<max[i])                 {                     max2=max[i];                     x1=i;                 }             }             if(max[i-1]+pao[i]>=pao[i])             {                 max[i]=max[i-1]+pao[i];             }         }         long long int max1=pao[1];         for(i=1;i<=n;i++)         {            if(max1<max[i])            {                x2=i;                max1=max[i];            }         }         cout<<"Case "<<j<<":"<<endl;         j++;         cout<<max1<<" "<<x1<<" "<<x2<<endl;     }     return 0; } ac代码

#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
int main()
{
    //freopen("r.txt","r",stdin);
    int n,m,sum,maxx,j,k;
    int a[100005];
    cin>>n;
    int ans=1,step;
    while(n--)
    {
        cin>>m;
        for(int i=0;i<m;i++)
        {
            scanf("%d",&a[i]);
        }
        sum=0;
        maxx=-1001;
        step=1;
        for(int i=0;i<m;i++)
        {
            sum+=a[i];
                if(sum>maxx)
                    {
                        j=step;
                        k=i+1;
                        maxx=sum;
                    }
            if(sum<0)
            {
                sum=0;
                step=i+2;
            }

        }
        cout<<"Case "<<ans++<<":"<<endl;
        cout<<maxx<<" "<<j<<" "<<k<<endl;
        if(n>0) cout<<endl;
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值